Package Details: gtk4-git 3.99.4.r42.g53cd499621-1

Git Clone URL: https://aur.archlinux.org/gtk4-git.git (read-only, click to copy)
Package Base: gtk4-git
Description: GObject-based multi-platform GUI toolkit (GIT Version)
Upstream URL: https://www.gtk.org/
Licenses: LGPL
Submitter: andrewSC
Maintainer: andrewSC
Last Packager: andrewSC
Votes: 15
Popularity: 0.007213
First Submitted: 2016-11-18 20:17
Last Updated: 2020-11-09 14:57

Dependencies (36)

Required by (0)

Sources (6)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

andrewSC commented on 2016-12-01 14:27

shoober420: I totally understand the annoyance however, since libepoxy in the official repos satisfies the configure.ac version requirement for epoxy, I'm going to have to stay with what's currently in the PKGBUILD.

shoober420 commented on 2016-11-30 22:33

Very minor thing. I use libepoxy-git and have to edit the PKGBUILD to simply be libepoxy to satisfy the dependencies.

shoober420 commented on 2016-11-28 22:31

Awesome, it builds ok now. Thank you very much sir.

andrewSC commented on 2016-11-28 14:33

shoober420: try rebuilding graphene-git and see if that fixes the issue for you.

shoober420 commented on 2016-11-27 16:22

This fails to build. GTK4 requires graphene 1.5.2 or higher. It seems 1.4.0 is the latest release in the arch repository, so I installed the graphene-git package from the AUR which seems to be at version 1.5.3 at the time of posting. Now with the graphene-git package installed, I get the following error during compile.

checking for GDK_DEP... yes
checking for GSK_DEP... no
configure: error: Package requirements (pango pangocairo gdk-pixbuf-2.0
>= 2.30.0 cairo >= 1.14.0 cairo-gobject >= 1.14.0 graphene-1.0 >= 1.5.1
epoxy >= 1.0 wayland-client >= 1.9.91 wayland-protocols >= 1.7 xkbcommon
>= 0.2.0 wayland-cursor >= 1.9.91 wayland-egl) were not met:

Variable 'exec_prefix' not defined in
'/usr/lib/pkgconfig/graphene-1.0.pc'

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GSK_DEP_CFLAGS
and GSK_DEP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

shoober420 commented on 2016-11-22 00:34

Wow, I can't wait to build this when I get home from work.

andrewSC commented on 2016-11-18 20:28

Hi all, I've build a gtk4-git base for continued development. If you have any critiques or feedback I'd love to hear it! Thanks!

Note: This package will eventually be merged into gtk4-git since gtk3 will be in the official repos.

gtk4-git base: https://aur.archlinux.org/pkgbase/gtk4-git/
gtk4-git: https://aur.archlinux.org/packages/gtk4-git/
gtk4-update-icon-cache-git: https://aur.archlinux.org/packages/gtk4-update-icon-cache-git/
gtk4-print-backends-git: https://aur.archlinux.org/packages/gtk4-print-backends-git/

andrewSC commented on 2016-10-26 11:12

Thanks for the heads up folks, I'll try to get this resolved asap. There's some more admin stuff I need to do, to update the package name.

shoober420 commented on 2016-10-26 03:27

This is for sure gtk4. This package no longer provides gtk3.so files. I tried to run deadbeef with the gtk3 plugin and it wouldn't run. I had to build deadbeef with gtk2 instead. Please update the PKGBUILD and package name to gtk4-git.

jtojnar commented on 2016-10-15 20:20

This is actually gtk4 now.