Package Details: gtk3-optional-csd 3.22.24-1

Git Clone URL: (read-only, click to copy)
Package Base: gtk3-optional-csd
Description: gobject-based gui toolkit with optionally enabled csd
Upstream URL:
Licenses: LGPL
Conflicts: gtk-update-icon-cache, gtk3, gtk3-print-backends
Provides: gtk-update-icon-cache, gtk3=3.22.24, gtk3-print-backends
Submitter: Earnest
Maintainer: None
Last Packager: Earnest
Votes: 9
Popularity: 0.000000
First Submitted: 2015-08-16 11:40
Last Updated: 2017-10-06 17:00

Required by (1000)

Sources (5)

Latest Comments

1 2 Next › Last »

Earnest commented on 2017-10-29 22:35

That's all folks.

Now that upstream has accepted KDE's SSD protocol[0] this fork becomes less necessary.

The patch also fails to apply on 3.22.25 so if anyone else picks this up that will need to be corrected.


gato_lento commented on 2017-01-14 16:31

pkgver needs to be changed to 3.22.6 and the first sha1sum to f16494bca63ac417dc91cb1ff62e2ed7dbb69f33

tidux commented on 2017-01-02 22:22

This package causes intermittent crashes with the gtk3 file picker called from Firefox or Qutebrowser that take the entire browser down. Doing a fresh rebuild/reinstall and flushing all the old copies from memory did not fix the problem.

Earnest commented on 2016-11-02 18:22

Hm, as this isn't a -git package as I'm used to, I can quite easily just use $pkgver, otherwise I really do dislike versioned dependencies. Shame pacman isn't able to figure this out itself.

klardotsh commented on 2016-11-02 16:01

According to the PKGBUILD wiki page, this *is* the responsibility of this package, and adapta-gtk-theme is handling versioned dependencies correctly:

"Warning: A version that the package provides should be mentioned (pkgver and perhaps the pkgrel), if packages needing the software may require one. For instance, a modified qt package version 3.3.8, named qt-foobar, should use provides=('qt=3.3.8'); using provides=('qt') would cause the dependencies that require a specific version of qt to fail. Do not add pkgname to the provides array, as it is done automatically."

Earnest commented on 2016-11-01 14:03

Fix adapta-gtk-theme, it's broken. I won't support versioned dependencies.

klardotsh commented on 2016-10-31 16:17

Oddly, this ends up conflicting with adapta-gtk-theme, despite providing gtk3:

==> Making package: adapta-gtk-theme (Mon Oct 31 11:14:59 CDT 2016)
==> Checking runtime dependencies...
==> Missing dependencies:
-> gtk3>=3.18.9
-> gtk3<=3.22.99
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.
The build failed.

snout commented on 2016-10-11 12:30

As glib2 in [core] is still version 2.48 (and the version of gtk3 in [extra] is still 3.20) compilation fails due to a dependency on glib >= 2.49. Seems to make sense to wait for glib2 2.50 and gtk 3.22 to get out of testing?

Earnest commented on 2016-05-21 11:10

Yeah good point, thanks.

Fixed and version bumped.

Stebalien commented on 2016-05-21 02:58

FYI, everything in the install file except the pre_remove hook can now be removed.