Package Details: gstreamer0.10-ffmpeg 0.10.13-10

Git Clone URL: https://aur.archlinux.org/gstreamer0.10-ffmpeg.git (read-only, click to copy)
Package Base: gstreamer0.10-ffmpeg
Description: Gstreamer FFMpeg Plugin
Upstream URL: http://gstreamer.freedesktop.org/
Licenses: GPL
Groups: gstreamer0.10-plugins
Submitter: yurikoles
Maintainer: bidulock
Last Packager: gcurse
Votes: 17
Popularity: 0.000001
First Submitted: 2017-01-26 13:47
Last Updated: 2018-04-11 06:54

Latest Comments

« First ‹ Previous 1 2 3 4

JoZ3 commented on 2017-01-27 12:48

Same here :(

jose1711 commented on 2017-01-27 08:06

same here

kiotoze commented on 2017-01-27 00:57

I got this error too

Swipe commented on 2017-01-26 22:51

I get the following error when trying to install this package:

In file included from /usr/include/gstreamer-0.10/gst/gst.h:32:0,
from gstffmpeg.c:29:
/usr/include/gstreamer-0.10/gst/gstversion.h:48:27: error: expected declaration specifiers or ‘...’ before ‘(’ token
#define GST_VERSION_MAJOR (0)
^
gstffmpeg.c:161:21: note: in expansion of macro ‘GST_VERSION_MAJOR’
GST_PLUGIN_DEFINE2 (GST_VERSION_MAJOR,
^~~~~~~~~~~~~~~~~
/usr/include/gstreamer-0.10/gst/gstversion.h:54:27: error: expected declaration specifiers or ‘...’ before ‘(’ token
#define GST_VERSION_MINOR (10)
^
gstffmpeg.c:162:5: note: in expansion of macro ‘GST_VERSION_MINOR’
GST_VERSION_MINOR,
^~~~~~~~~~~~~~~~~
gstffmpeg.c:163:5: error: unknown type name ‘ffmpeg’
ffmpeg,
^~~~~~
gstffmpeg.c:164:5: error: expected declaration specifiers or ‘...’ before string constant
"All FFmpeg codecs and formats (" FFMPEG_SOURCE ")",
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
gstffmpeg.c:165:5: error: expected declaration specifiers or ‘...’ before ‘plugin_init’
plugin_init, PACKAGE_VERSION,
^~~~~~~~~~~
In file included from gstffmpegutils.h:24:0,
from gstffmpeg.c:39:
../../config.h:140:25: error: expected declaration specifiers or ‘...’ before string constant
#define PACKAGE_VERSION "0.10.13"
^
gstffmpeg.c:165:18: note: in expansion of macro ‘PACKAGE_VERSION’
plugin_init, PACKAGE_VERSION,
^~~~~~~~~~~~~~~
gstffmpeg.c:169:5: error: expected declaration specifiers or ‘...’ before string constant
"GPL",
^~~~~
gstffmpeg.c:171:5: error: expected declaration specifiers or ‘...’ before string constant
"FFmpeg", "http://ffmpeg.org/")
^~~~~~~~
gstffmpeg.c:171:15: error: expected declaration specifiers or ‘...’ before string constant
"FFmpeg", "http://ffmpeg.org/")
^~~~~~~~~~~~~~~~~~~~
gstffmpeg.c:129:1: warning: ‘plugin_init’ defined but not used [-Wunused-function]
plugin_init (GstPlugin * plugin)
^~~~~~~~~~~
make[3]: *** [Makefile:584: libgstffmpeg_la-gstffmpeg.lo] Error 1
make[3]: Leaving directory '/home/swipe/.cache/pacaur/gstreamer0.10-ffmpeg/src/gst-ffmpeg/ext/ffmpeg'
make[2]: *** [Makefile:449: all-recursive] Error 1
make[2]: Leaving directory '/home/swipe/.cache/pacaur/gstreamer0.10-ffmpeg/src/gst-ffmpeg/ext'
make[1]: *** [Makefile:543: all-recursive] Error 1
make[1]: Leaving directory '/home/swipe/.cache/pacaur/gstreamer0.10-ffmpeg/src/gst-ffmpeg'
make: *** [Makefile:472: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
:: failed to build gstreamer0.10-ffmpeg package(s)