Package Details: grimshot 1.6-1

Git Clone URL: https://aur.archlinux.org/grimshot.git (read-only, click to copy)
Package Base: grimshot
Description: A helper for screenshots within sway.
Upstream URL: https://github.com/swaywm/sway
Licenses: MIT
Replaces: swaygrab
Submitter: whynothugo
Maintainer: whynothugo
Last Packager: whynothugo
Votes: 6
Popularity: 0.139146
First Submitted: 2020-05-01 08:22
Last Updated: 2021-04-18 13:29

Latest Comments

1 2 Next › Last »

ggnoredo commented on 2021-04-28 18:25

@whynothugo it's the same on updating or installing

==> Making package: grimshot 1.6-1 (Wed 28 Apr 2021 09:24:42 PM +03)
==> Retrieving sources...
  -> Downloading grimshot-1.6...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  4190  100  4190    0     0   8088      0 --:--:-- --:--:-- --:--:--  8088
  -> Downloading grimshot-1.6.1.scd...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1762  100  1762    0     0   3830      0 --:--:-- --:--:-- --:--:--  3822
==> Validating source files with md5sums...
    grimshot-1.6 ... Passed
    grimshot-1.6.1.scd ... Passed
==> Making package: grimshot 1.6-1 (Wed 28 Apr 2021 09:24:44 PM +03)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found grimshot-1.6
  -> Found grimshot-1.6.1.scd
==> Validating source files with md5sums...
    grimshot-1.6 ... Passed
    grimshot-1.6.1.scd ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
==> Sources are ready.
grimshot-1.6-1: parsing pkg list...
==> Making package: grimshot 1.6-1 (Wed 28 Apr 2021 09:24:45 PM +03)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Removing existing $pkgdir/ directory...
==> Starting build()...
==> Entering fakeroot environment...
==> Starting package()...
install: failed to access 'grimshot-1.6/usr/bin/grimshot': Not a directory
==> ERROR: A failure occurred in package().
    Aborting...
:: Packages failed to build: grimshot-1.6-1

whynothugo commented on 2021-04-26 09:34

@ggnoredo Can you provide the full output? Is this when installing or running?

ggnoredo commented on 2021-04-25 12:19

failed to access 'grimshot-1.6/usr/bin/grimshot': Not a directory

nloewen commented on 2021-04-19 15:35

Please also bump the pkgrel to go with the latest fix

whynothugo commented on 2021-04-18 13:29

I've pushed an updated version. I've no idea how I broke that, especially since I built and installed it locally.

sperg512 commented on 2021-04-17 23:11

@jso8910 doesn't work, just gives the following error:

  -> Downloading grimshot-1.6/usr/bin/grimshot...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0Warning: Failed to create the file grimshot-1.6/usr/bin/grimshot.part: No such 
Warning: file or directory
 20  4190   20   865    0     0   3760      0  0:00:01 --:--:--  0:00:01  3760
curl: (23) Failure writing output to destination

Here's one that does work:

--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,5 +29,5 @@ package() {
   cd "$srcdir/"

   install -Dm 644 grimshot.1 "$pkgdir/usr/share/man/man1/grimshot.1"
-  install -Dm 755 grimshot "$pkgname-$pkgver/usr/bin/grimshot"
+  install -Dm 755 grimshot-$pkgver "$pkgdir/usr/bin/grimshot"
 }

jso8910 commented on 2021-04-17 15:49

Here is a fix for the build issue.

--- a/PKGBUILD   2021-04-17 23:48:04.391502926 +0800
+++ b/PKGBUILD    2021-04-17 23:47:51.341568173 +0800
@@ -13,7 +13,7 @@
             'wl-clipboard: Copy screenshots')
 makedepends=("scdoc")
 source=(
-  "$pkgname-$pkgver::https://raw.githubusercontent.com/swaywm/sway/${pkgver}/contrib/grimshot"
+  "$pkgname-$pkgver/usr/bin/grimshot::https://raw.githubusercontent.com/swaywm/sway/${pkgver}/contrib/grimshot"
   "$pkgname-$pkgver.1.scd::https://raw.githubusercontent.com/swaywm/sway/${pkgver}/contrib/grimshot.1.scd"
 )
 md5sums=('c39dda47a87a0583d6f9e54eb35cdead'

Pretty simple the maintainer needs to fix this quickly because otherwise users cannot update sway.

quietvoid commented on 2021-04-17 01:49

The package does not build:

==> Starting package()...
install: failed to access 'grimshot-1.6/usr/bin/grimshot': Not a directory
==> ERROR: A failure occurred in package().

whynothugo commented on 2021-04-16 23:42

Fixed.

Please don't report package out of date if there are issues with it. I don't need a second email with you repeating the same thing.

liljaylj commented on 2021-04-16 20:51

@whynothugo hello, sway uses tag 1.6 instead of 1.6.0

pkgver=1.6
pkgrel=1