Package Details: grass 7.8.1-1

Git Clone URL: https://aur.archlinux.org/grass.git (read-only)
Package Base: grass
Description: Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization
Upstream URL: http://grass.osgeo.org/
Licenses: GPL
Submitter: Scimmia
Maintainer: Scimmia
Last Packager: Scimmia
Votes: 35
Popularity: 1.08
First Submitted: 2015-09-06 15:10
Last Updated: 2019-11-12 15:07

Dependencies (27)

Required by (1)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

Scimmia commented on 2016-12-06 23:54

gdal requires libmariadbclient, do you have this installed and is it up to date?

kokkytos commented on 2016-12-06 22:25

The contents of ./src/grass-7.0.5/config.log:
http://pastebin.com/XjUuANgL

Scimmia commented on 2016-12-06 15:32

We'll need to see config.log. Put it in a pastebin somewhere and post the link here.

kokkytos commented on 2016-12-06 15:11

I'm using community/gdal 2.1.1-3

Scimmia commented on 2016-11-23 01:46

@kokkytos, are you using the gdal package from the Extra repo?

kokkytos commented on 2016-11-20 20:47

I get the following error:

checking whether to use GDAL... yes
checking for gdal-config... /usr/bin/gdal-config
configure: error: *** Unable to locate GDAL library.
==> ERROR: A failure occurred in build().
Aborting...

Scimmia commented on 2016-08-17 13:21

@scummos, no. Read the AUR wiki page.

scummos commented on 2016-08-17 09:17

This needs to additionally depend on
core/flex
community/byacc
or the build will fail.

kikislater commented on 2016-06-04 09:08

Another PKGBUILD here (from official grass gis website) :
https://gitlab.com/tutturu/grass7_pkgbuild

Better options according to common GIS usage with Grass

SmokeyD commented on 2016-05-20 01:48

I had the build problems as well like all previous commenters with GCC6. I also tried using GCC5 and GCC4.something from AUR, but it didn't want to build. Today I just tried installing again form AUR without any modifications and it just built and installed fine without trouble. I assume @Scimmia did something in the PKGBUILD to make it compile correctly with GCC6. If so, it worked like a charm for me. Thanks a lot!