Package Details: gr-osmosdr-git d77577-1

Git Clone URL: https://aur.archlinux.org/gr-osmosdr-git.git (read-only, click to copy)
Package Base: gr-osmosdr-git
Description: GNU Radio source block for OsmoSDR, which is a 100% Free Software based small form-factor inexpensive SDR (Software Defined Radio) project.
Upstream URL: http://sdr.osmocom.org/trac/
Licenses: GPL
Provides: gnuradio-osmosdr, gr-osmosdr
Submitter: 0xfc
Maintainer: karel
Last Packager: karel
Votes: 30
Popularity: 0.000362
First Submitted: 2012-04-24 04:44
Last Updated: 2020-04-15 09:53

Required by (15)

Sources (1)

Pinned Comments

karel commented on 2019-09-03 14:54

For GNU Radio 3.9!

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

0xfc commented on 2013-06-17 06:17

Added pkgver.

swiftgeek commented on 2013-06-15 21:19

please add pkgver with date flavor ;)

pkgver() {
date +%Y%m%d
}

Also for 3.6.x use gr3.6 branch, to do so change:
git clone "$_gitroot" "$_gitname"
to
git clone -b gr3.6 "$_gitroot" "$_gitname"

swiftgeek commented on 2013-06-15 21:11

please add pkgver with date flavor ;)

pkgver() {
date +%Y%m%d
}

asdil12 commented on 2013-06-13 06:38

Just reinstall the gnuradio-git pkg - it still points to tbe latest gnuradio git version.

DL0 commented on 2013-06-12 22:44

The version of gr-osmosdr in git now requires gnuradio >= 3.7 to compile. The gnuradio and gnuradio-git packages in AUR are 3.6.

DL0 commented on 2013-06-12 22:40

The current version of gr-osmosdr in git now required gnuradio >= 3.7 to build so it will fail to compile with any version of gnuradio in AUR. Has anyone tried modifying the gnuradio-git in AUR to grab the 3.7 version?

0xfc commented on 2013-05-24 07:17

Added boost to makedepends.

Nidhogg commented on 2013-05-23 12:49

I had to include boost in 'makedepends' before I could successfully build the package. Without boost, I got this error message:

-- Configuring Boost C++ Libraries...
-- Could NOT find Boost
CMake Error at CMakeLists.txt:119 (message):
Boost required to build gr-osmosdr


-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().
Aborting...

Nidhogg commented on 2013-05-23 12:43

I had to include boost in 'depends' before I could successfully build the package. Without boost, I got this error message:

-- Configuring Boost C++ Libraries...
-- Could NOT find Boost
CMake Error at CMakeLists.txt:119 (message):
Boost required to build gr-osmosdr


-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().
Aborting...

ackalker commented on 2013-04-05 20:53

You're welcome :-)