Package Details: gr-osmosdr-git d77577-1

Git Clone URL: https://aur.archlinux.org/gr-osmosdr-git.git (read-only, click to copy)
Package Base: gr-osmosdr-git
Description: GNU Radio source block for OsmoSDR, which is a 100% Free Software based small form-factor inexpensive SDR (Software Defined Radio) project.
Upstream URL: http://sdr.osmocom.org/trac/
Licenses: GPL
Provides: gnuradio-osmosdr, gr-osmosdr
Submitter: 0xfc
Maintainer: karel
Last Packager: karel
Votes: 30
Popularity: 0.000362
First Submitted: 2012-04-24 04:44
Last Updated: 2020-04-15 09:53

Required by (15)

Sources (1)

Pinned Comments

karel commented on 2019-09-03 14:54

For GNU Radio 3.9!

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

0xfc commented on 2013-07-23 10:39

Changed dependency back to gnuradio.

asdil12 commented on 2013-07-22 19:01

@0xfc:
please change the dependency back to gnuradio, as gnuradio-3-7-0 is now available, and depending on gnuradio-git breaks the non-git version of gqrx.

0xfc commented on 2013-07-02 12:28

Updated dependency 'gnuradio' to 'gnuradio-git'.

asdil12 commented on 2013-06-29 12:22

@masutu: append "#branch=gr3.6" to the git:// url

masutu commented on 2013-06-29 12:20

Hi,
won't build atm:

"
CMake Warning at CMakeLists.txt:147 (find_package):
Could not find a configuration file for package "Gnuradio" that is
compatible with requested version "3.7.0".

The following configuration files were considered but not accepted:

/usr/lib/cmake/gnuradio/GnuradioConfig.cmake, version: 3.6.5.0
/lib/cmake/gnuradio/GnuradioConfig.cmake, version: 3.6.5.0
...
"

I think solution would either be make it depend on gnuradio-git, which already is 3.7 series, or to do "git checkout gr3.6" before building (see http://sdr.osmocom.org/trac/wiki/GrOsmoSDR#Buildprocess).

0xfc commented on 2013-06-26 05:01

Corrected this typo.
Sorry for the late, but the end-term exams are coming, I'm busy on it. *O.O*

qs9rx commented on 2013-06-23 18:06

You have a typo, it is "source" not "sources" for the git repository. ;)

0xfc commented on 2013-06-23 08:11

Updated PKGBUILD with VCS guidelines.

asdil12 commented on 2013-06-23 05:40

Please swtch to the new vcs source as described in here:
https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines

When you have a git:// url you can simply write
sources=('git://...')
md5sums=('SKIP')

You can select the branch by apppending #branch=gr3.6 to the url.

DL0 commented on 2013-06-23 01:38

Thanks swiftgeek for the info on the gr3.6 branch. After updating everything to gnuradio 3.7 I found none of my GRC radios worked although I could build new ones. This small PKGBUILD change will save me a lot of trouble!