Package Details: gr-osmosdr-git 0.1.4.48.g86ad584-1

Git Clone URL: https://aur.archlinux.org/gr-osmosdr-git.git (read-only)
Package Base: gr-osmosdr-git
Description: GNU Radio source block for OsmoSDR, which is a 100% Free Software based small form-factor inexpensive SDR (Software Defined Radio) project.
Upstream URL: http://sdr.osmocom.org/trac/
Licenses: GPL
Provides: gnuradio-osmosdr, gr-osmosdr
Submitter: 0xfc
Maintainer: karel
Last Packager: yhfudev
Votes: 30
Popularity: 0.001082
First Submitted: 2012-04-24 04:44
Last Updated: 2015-10-07 17:47

Required by (15)

Sources (1)

Pinned Comments

karel commented on 2019-09-03 14:54

Until gr-osmosdr is ported to work with GNU Radio 3.8, this package doesn't work with the GNU Radio installed from official Arch repositories. Check the progress at https://osmocom.org/issues/3855.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

swiftgeek commented on 2013-08-01 02:26

but somehow 0 > v so local is always outdated… and v comes from version…

(in previous comment i forgot about that 'v' might be included in ¿short hash)
git describe --always | sed 's|-|.|g; s|^.||'

---
Also `cd $_gitname` has to be uncommented
fatal: Not a git repository

swiftgeek commented on 2013-08-01 02:15

but somehow 0 > v so local is always outdated… and v comes from version…

0xfc commented on 2013-08-01 02:14

Reverted commented git command line in pkgver().

swiftgeek commented on 2013-07-31 23:35

Slight overkill :D
consider
pkgver=0 # in "header", just like it's now
git describe --always | sed 's|-|.|g; s|v||g' # in pkgver()

swiftgeek commented on 2013-07-31 23:22

Slight overkill :D
consider
pkgver=0
git describe --always | sed 's|-|_|g; s|v||g' # in pkgver()

0xfc commented on 2013-07-28 04:23

Set pkgver to constant value 0.

swiftgeek commented on 2013-07-27 17:59

Please set pkgver to 0 (otherwise yaourt and other AUR helpers will constantly try to update this package )

0xfc commented on 2013-07-23 10:39

Changed dependency back to gnuradio.

asdil12 commented on 2013-07-22 19:01

@0xfc:
please change the dependency back to gnuradio, as gnuradio-3-7-0 is now available, and depending on gnuradio-git breaks the non-git version of gqrx.

0xfc commented on 2013-07-02 12:28

Updated dependency 'gnuradio' to 'gnuradio-git'.