Package Details: gr-osmosdr-git d77577-1

Git Clone URL: https://aur.archlinux.org/gr-osmosdr-git.git (read-only, click to copy)
Package Base: gr-osmosdr-git
Description: GNU Radio source block for OsmoSDR, which is a 100% Free Software based small form-factor inexpensive SDR (Software Defined Radio) project.
Upstream URL: http://sdr.osmocom.org/trac/
Licenses: GPL
Provides: gnuradio-osmosdr, gr-osmosdr
Submitter: 0xfc
Maintainer: karel
Last Packager: karel
Votes: 30
Popularity: 0.000362
First Submitted: 2012-04-24 04:44
Last Updated: 2020-04-15 09:53

Required by (15)

Sources (1)

Pinned Comments

karel commented on 2019-09-03 14:54

For GNU Radio 3.9!

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

swiftgeek commented on 2014-08-03 18:08

works on stable gnuradio so if anything PKGBUILD could detect installed version if that's helps at all (compiling gr takes way too much time)
@Zygote: logs… Most probably missed (indirect) dependency of this package is causing this

0xfc commented on 2014-08-03 14:25

Sorry I've switched to Ubuntu and no longer using Arch, so I don't know if it will work.
Long ago there was someone who requested to switch to gnuradio-git, but other people complained about broken boost dependency.
So if you made it work, please tell me, and I'll update the dependency. Also, I can abandon this package if someone wants to maintance it.

ardevd commented on 2014-08-03 01:58

Is it possible to make this work with the gnuradio-git package at all? Currently it doesnt seem to be due to osmosdr looking for older .so files than what the gnuradio-git package generates.

0xfc commented on 2014-03-11 00:11

Sorry I currently don't have a computer in hand, so I'll check it on Saturday.

rek2gnulinux commented on 2014-03-10 23:19

add to the CNAME line in the pkgbuild before installing -DENABLE_BLADERF:BOOL=OFF
this will let you install the rest of the modules.. just not BLADERF that is the one giving the problem..
hispagatos.org

0xfc commented on 2014-01-13 03:18

Seems an upstream bug. Did this happen before?

test0 commented on 2014-01-13 00:53

lib/CMakeFiles/gnuradio-osmosdr.dir/build.make:356: recipe for target 'lib/CMakeFiles/gnuradio-osmosdr.dir/bladerf/bladerf_source_c.cc.o' failed
make[2]: *** [lib/CMakeFiles/gnuradio-osmosdr.dir/bladerf/bladerf_source_c.cc.o] Error 1
CMakeFiles/Makefile2:124: recipe for target 'lib/CMakeFiles/gnuradio-osmosdr.dir/all' failed
make[1]: *** [lib/CMakeFiles/gnuradio-osmosdr.dir/all] Error 2
Makefile:126: recipe for target 'all' failed


I installed bladerf directly but the error persists.

0xfc commented on 2013-11-02 03:17

Added python2-cheetah to makedepends.

gog commented on 2013-11-02 03:00

Build depends on python2-cheetah. I don't know about runtime. You should add it.

swiftgeek commented on 2013-08-01 02:39

yes