Package Details: gr-osmosdr-git d77577-1

Git Clone URL: https://aur.archlinux.org/gr-osmosdr-git.git (read-only, click to copy)
Package Base: gr-osmosdr-git
Description: GNU Radio source block for OsmoSDR, which is a 100% Free Software based small form-factor inexpensive SDR (Software Defined Radio) project.
Upstream URL: http://sdr.osmocom.org/trac/
Licenses: GPL
Provides: gnuradio-osmosdr, gr-osmosdr
Submitter: 0xfc
Maintainer: karel
Last Packager: karel
Votes: 30
Popularity: 0.000356
First Submitted: 2012-04-24 04:44
Last Updated: 2020-04-15 09:53

Required by (15)

Sources (1)

Pinned Comments

karel commented on 2019-09-03 14:54

For GNU Radio 3.9!

Latest Comments

1 2 3 4 5 6 ... Next › Last »

maximevince commented on 2020-09-28 09:50

It seems the git repo does not exist anymore...

bidi commented on 2020-04-15 08:10

The build part appears to be wrong:

... cmake -DPYTHON_EXECUTABLE=$(which python2) \ -DPYTHON_INCLUDE_DIR=$(echo /usr/include/python2) \ -DPYTHON_LIBRARY=$(echo /usr/lib/libpython2..so) \ ...

doesn't work, as is looking for Pythonlibs 3. Changing from 2 to 3 make it working. Don't know the impact of it at runtime yet.

deadite66 commented on 2019-09-28 08:55

the call is out for a new maintainer for gr-osmosdr.

https://osmocom.org/news/112

karel commented on 2019-09-03 14:54

For GNU Radio 3.9!

jdsnape commented on 2019-09-03 14:42

This fails for me with the error -- Checking for module 'gnuradio-fcd' -- Package 'gnuradio-fcd', required by 'virtual:world', not found

vnuke commented on 2019-05-05 23:38

it seems that gr-osmosdr won't build with gnuradio-git (version 3.8) because of a change in cmake usage in gnuradio. ref:https://osmocom.org/issues/3855

karel commented on 2019-02-28 07:55

I expect that for the gr-osmosdr to work with the latest gnuradio (i.e., 3.8), considerable changes in upstream are required besides the log4cpp linking issues.

maximevince commented on 2019-02-27 17:38

I had to add: -DCMAKE_EXE_LINKER_FLAGS=-llog4cpp -DCMAKE_MODULE_LINKER_FLAGS=-llog4cpp -DCMAKE_SHARED_LINKER_FLAGS=-llog4cpp to the cmake arguments to get it to compile.

Otherwise I'd get errors related to: soapy_sink_c.cc log4cpp AppenderMapStorageInitializer

bastla commented on 2019-01-25 13:26

The libbladerf-git is needed within the current compiler config and should be added as a dependency.

maximevince commented on 2018-06-10 10:23

This should fix boost-1.6.7 compatibility:

diff -ura gr-osmosdr.orig/lib/CMakeLists.txt gr-osmosdr/lib/CMakeLists.txt --- gr-osmosdr.orig/lib/CMakeLists.txt 2018-06-10 12:06:35.662484236 +0200 +++ gr-osmosdr/lib/CMakeLists.txt 2018-06-10 12:06:51.886207437 +0200 @@ -43,6 +43,8 @@ time_spec.cc )

+list(APPEND Boost_LIBRARIES pthread) + GR_OSMOSDR_APPEND_LIBS( ${Boost_LIBRARIES} ${GNURADIO_ALL_LIBRARIES}