Package Details: gr-limesdr 2.0.0-1

Git Clone URL: https://aur.archlinux.org/gr-limesdr.git (read-only, click to copy)
Package Base: gr-limesdr
Description: gr-limesdr Plugin for GNURadio
Upstream URL: https://github.com/myriadrf/gr-limesdr
Licenses: MIT
Submitter: FFY00
Maintainer: FFY00
Last Packager: FFY00
Votes: 1
Popularity: 0.000000
First Submitted: 2018-06-13 10:33
Last Updated: 2019-08-23 08:13

Required by (0)

Sources (1)

Latest Comments

nickoe commented on 2020-10-11 13:22

I get the same problem as @maverick1707. It looks like the package hardcode paths to python3.7 while the latest default python3 on arch is 3.8. Even if I try to update that I get issues....

maverick1707 commented on 2020-04-18 20:31

The package is not working.

this is the error that apperas when it is compiling.

`` -- Configuring LimeSuite C++ Libraries... -- Checking for module 'LimeSuite' -- Found LimeSuite, version 20.01.0-20.01.0 -- Found LimeSuite: /usr/include/lime, /usr/lib/libLimeSuite.so -- -- Checking for module SWIG -- Found SWIG version 4.0.1. -- Found SWIG: /usr/bin/swig
-- Found PythonLibs: /usr/lib/libpython3.7m.so (Required is at least version "2") -- PYTHON_EXECUTABLE not set - using default python3 -- Use -DPYTHON_EXECUTABLE=/path/to/python2 to build for python2. -- Found PythonInterp: /usr/bin/python (found version "3.8.2") -- Found PythonLibs: /usr/lib/libpython3.7m.so (Required is exact version "3.8") -- User set python executable /usr/bin/python -- User set python executable /usr/bin/python -- Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE) -- Configuring done CMake Error in swig/CMakeLists.txt: Imported target "Python::Python" includes non-existent path

"/usr/include/python3.7m"

in its INTERFACE_INCLUDE_DIRECTORIES. Possible reasons include:

  • The path was deleted, renamed, or moved to another location.

  • An install or uninstall procedure did not complete successfully.

  • The installation package was faulty and references files it does not provide.

CMake Error in swig/CMakeLists.txt: Imported target "Python::Python" includes non-existent path

"/usr/include/python3.7m"

in its INTERFACE_INCLUDE_DIRECTORIES. Possible reasons include:

  • The path was deleted, renamed, or moved to another location.

  • An install or uninstall procedure did not complete successfully.

  • The installation package was faulty and references files it does not provide.

``

dvalter commented on 2019-09-03 10:48

Does not build due to Doxygen error. However it's possible to add -DENABLE_DOXYGEN=off to cmake arguments to build without doxygen.

Miegl commented on 2019-08-31 16:39

It also doesn't build with doxygen

FFY00 commented on 2019-08-26 07:35

This probably happens because you have graphviz installed. It's not optimal but I don't have the time right now to fix the upstream. If you have a patch fixing this issue please let me know.

To build the package please uninstall graphviz or build it in a clean chroot (recommended). See https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_clean_chroot#Convenience_way,

backerman commented on 2019-08-24 16:06

This package is failing to build:

[ 50%] Generating python docstrings for limesdr_swig_doc
Traceback (most recent call last):
  File "/home/bsa3/.cache/yay/gr-limesdr/src/gr-limesdr-2.0.0/docs/doxygen/swig_doc.py", line 255, in <module>
    make_swig_interface_file(di, swigdocfilename, custom_output=custom_output)
  File "/home/bsa3/.cache/yay/gr-limesdr/src/gr-limesdr-2.0.0/docs/doxygen/swig_doc.py", line 222, in make_swig_interface_file
    output.append(make_class_entry(k))
  File "/home/bsa3/.cache/yay/gr-limesdr/src/gr-limesdr-2.0.0/docs/doxygen/swig_doc.py", line 141, in make_class_entry
    output.append(make_entry(klass, description=description))
  File "/home/bsa3/.cache/yay/gr-limesdr/src/gr-limesdr-2.0.0/docs/doxygen/swig_doc.py", line 104, in make_entry
    description = combine_descriptions(obj)
  File "/home/bsa3/.cache/yay/gr-limesdr/src/gr-limesdr-2.0.0/docs/doxygen/swig_doc.py", line 84, in combine_descriptions
    return utoascii('\n\n'.join(description)).strip()
  File "/home/bsa3/.cache/yay/gr-limesdr/src/gr-limesdr-2.0.0/docs/doxygen/swig_doc.py", line 69, in utoascii
    out = out.replace('"', '\\"')
TypeError: a bytes-like object is required, not 'str'
make[2]: *** [swig/CMakeFiles/limesdr_swig_swig_doc.dir/build.make:61: swig/limesdr_swig_doc.i] Error 1
make[1]: *** [CMakeFiles/Makefile2:318: swig/CMakeFiles/limesdr_swig_swig_doc.dir/all] Error 2
make: *** [Makefile:141: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...