Package Details: gr-limesdr-git r79.0a1f587-1

Git Clone URL: https://aur.archlinux.org/gr-limesdr-git.git (read-only, click to copy)
Package Base: gr-limesdr-git
Description: gr-limesdr Plugin for GNURadio
Upstream URL: https://github.com/myriadrf/gr-limesdr
Keywords: gnuradio gr lime limesdr limesuite radio sdr
Licenses: MIT
Conflicts: gr-limesdr
Provides: gr-limesdr
Submitter: FFY00
Maintainer: FFY00
Last Packager: FFY00
Votes: 3
Popularity: 0.012887
First Submitted: 2018-04-25 13:18
Last Updated: 2020-01-07 00:13

Latest Comments

nickoe commented on 2020-10-11 13:25

I am getting build errors with this, such as:

/tmp/gr-limesdr-git/src/gr-limesdr/build/swig/CMakeFiles/limesdr_swig.dir/limesdr_swigPYTHON_wrap.cxx: In function ‘PyObject* _wrap_source_make(PyObject*, PyObject*, PyObject*)’:
/tmp/gr-limesdr-git/src/gr-limesdr/build/swig/CMakeFiles/limesdr_swig.dir/limesdr_swigPYTHON_wrap.cxx:5000:78: error: no matching function for call to ‘gr::limesdr::source::make(std::string&, int&, const string&)’
 5000 |       result = gr::limesdr::source::make(arg1,arg2,(std::string const &)*arg3);

I got this locally from before

pacman -Qs lime |grep \/
local/gr-limesdr-git r88.ff642ba-1
local/limesuite 20.07.0-1

heliochronix commented on 2020-01-07 02:18

Awesome, thank you so much!

FFY00 commented on 2020-01-07 00:15

Sorry, things have been busy and I completely forgot about this. Next time feel free to ping me more often :)

Should be working now.

heliochronix commented on 2020-01-06 23:49

Hello again,

I don't mean to bother you again about this, but this package still does not build on an up-to-date system. The upstream "master" branch depending on GR 3.7, while Arch has moved on to 3.8.

If you like, I can send you a PKGBUILD and .SRCINFO patch that builds off the upstream "gr-3.8" branch meant to support GNURadio 3.8. I've already tested it and it builds successfully.

FFY00 commented on 2019-10-08 07:58

Oh, thanks for letting me know!

heliochronix commented on 2019-10-07 20:08

Hello,

Since Arch has moved to GNURadio 3.8, and gr-limesdr has a gr-3.8 branch to build, may I suggest updating this package to point to the 3.8 branch of gr-limesdr? As it stands, the package does not build against an up-to-date Arch system.

Thank you!