Package Details: gqrx-git 20200115-1

Git Clone URL: https://aur.archlinux.org/gqrx-git.git (read-only, click to copy)
Package Base: gqrx-git
Description: SDR receiver for Funcube Dongle, RTL-SDR, USRP and OsmoSDR devices.
Upstream URL: http://gqrx.dk/
Licenses: GPL
Conflicts: gqrx
Submitter: ivanovp
Maintainer: ivanovp
Last Packager: ivanovp
Votes: 38
Popularity: 0.000047
First Submitted: 2012-06-30 13:13
Last Updated: 2020-01-21 19:22

Latest Comments

« First ‹ Previous 1 2 3 4 5 6

ivanovp commented on 2013-01-24 15:11

Dependency of python2-cheetah was added.

adampolski commented on 2013-01-20 17:43

I think python2-cheetah should be added to the list of dependencies

Gringo commented on 2012-07-31 14:32

I supplied a patch upstream at the gqrx forum [1]. The patch was applied to the git-master branch yesterday. The application compiles succesfully now without the need of patches in AUR.
Removed the out-of-date flag.

[1] https://groups.google.com/forum/#!topic/gqrx/fDkQfvAMhsA

Gringo commented on 2012-07-27 12:24

If you have upgraded to boost 1.50.0 you will notice that gqrx will not link correctly and exits with the following error:

/usr/bin/ld: main.o: undefined reference to symbol '_ZN5boost6system15system_categoryEv'
/usr/bin/ld: note: '_ZN5boost6system15system_categoryEv' is defined in DSO /usr/lib/libboost_system.so.1.50.0 so try adding it to the linker command line
/usr/lib/libboost_system.so.1.50.0: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [gqrx] Error 1

This is because the recently released boost 1.5 library requires an explicit link to the libboost_library. This can be done by modifying the gqrx.pro file as follows:

1) Search for the line containing LIBS
2) Change it to: LIBS += -lboost_system -lrt

A made a simple patch to fix this. You can download it from my Dropbox shared folder: http://db.tt/df2GmviD

Gringo commented on 2012-07-27 12:04

If you recently built gqrx's dependencies you will have noticed that gqrx won't built anymore. This is because the recently released boost 1.5 library requires an explicit link to the libboost_library. This can be done by modifying the gqrx.pro file as follows:

1) Search for the line containing LIBS
2) Change it to: LIBS += -lboost_system -lrt

A made a simple patch to fix this. You can download it from my Dropbox shared folder: http://db.tt/df2GmviD

ivanovp commented on 2012-07-01 14:10

libuhd should be installed prior to compiling gr-osmosdr-git and gnuradio-git if you want to use RTL2832 devices!

ivanovp commented on 2012-07-01 14:10

libuhd should be installed prior to compiling gr-osmosdr-git and gnuradio-git!

ivanovp commented on 2012-07-01 13:52

libuhd should be installed prior to compiling gnuradio-git!