Package Details: gplates 2.1.0-2

Git Clone URL: https://aur.archlinux.org/gplates.git (read-only, click to copy)
Package Base: gplates
Description: Desktop software for the interactive visualisation of plate-tectonics
Upstream URL: https://www.gplates.org/
Licenses: GPL
Submitter: ralismark
Maintainer: ralismark
Last Packager: ralismark
Votes: 1
Popularity: 0.033561
First Submitted: 2019-01-28 01:23
Last Updated: 2019-02-16 10:18

Latest Comments

phundrak commented on 2020-02-28 10:56

Last August, GPlates 2.2.0 has been released. This is how I modified the PKGBUILD in order to get the latest version:

diff --git a/PKGBUILD b/PKGBUILD
index e698485..95dcea6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,20 @@
 # Maintainer: Timmy Yao <timmy.yao@outlook.com.au>
 pkgname=gplates
-pkgver=2.1.0
-pkgrel=2
+pkgver=2.2.0
+pkgrel=3
 pkgdesc="Desktop software for the interactive visualisation of plate-tectonics"
 arch=(x86_64)
 url="https://www.gplates.org/"
 license=('GPL')
 depends=(qt4 qwt-qt4 gdal)
 makedepends=(cmake glu glew python2 boost mesa cgal proj)
-source=("https://downloads.sourceforge.net/project/gplates/gplates/2.1/gplates-$pkgver-unixsrc.tar.bz2"
-        "no-ansi.patch"
+source=("https://downloads.sourceforge.net/project/gplates/gplates/2.2/gplates-$pkgver-unixsrc.tar.bz2"
         "icon.png"
         "gplates.desktop")
-md5sums=('770758823ac480e40213a5b284d273fc'
-         '57f9fb5b981456bdc874094d35488763'
+md5sums=('4d86607a35593720af5b741bb7ddb243'
          '938ef5a002905872a633665637a45d77'
          '1127c6a17abfa7500280fd09ce475a15')

-prepare() {
-       cd "$srcdir/$pkgname-$pkgver"
-       patch -Np2 -i "$srcdir/no-ansi.patch"
-}
-
 build() {
        cd "$srcdir/$pkgname-$pkgver"
        QTDIR=/usr/lib/qt4 cmake \
 }

The no-ansi patch is no longer needed as it is now an option added or not by Cmake depending on the compiler (the patch isn’t compatible with the current source code anyway). By the way, I also noticed that modifying make to make -j sometimes triggers a failed build. I could not reproduce this bug though.

ralismark commented on 2019-02-16 10:19

Moved gdal to depends. Should now be fixed.

sekret commented on 2019-02-14 09:04

$ gplates

gplates: error while loading shared libraries: libgdal.so.20: cannot open shared object file: No such file or directory

Please add gdal to depends