Package Details: goxel 0.10.6-1

Git Clone URL: https://aur.archlinux.org/goxel.git (read-only, click to copy)
Package Base: goxel
Description: 3D program that lets you create voxel volumes
Upstream URL: https://goxel.xyz/
Keywords: voxel
Licenses: GPL3
Submitter: tesfabpel
Maintainer: tesfabpel
Last Packager: City-busz
Votes: 11
Popularity: 0.99
First Submitted: 2017-02-07 11:29
Last Updated: 2020-06-17 15:43

Latest Comments

StuckUpCreations commented on 2020-06-12 21:28

@tesfabpel thank you, installed fine :)

tesfabpel commented on 2020-06-12 18:23

@RastaManKing fixed by disabling treating all warnings as error in the Makefile.

StuckUpCreations commented on 2020-06-11 21:18

cc1: note: unrecognized command-line option ‘-Wno-unknown-warning-option’ may have been intended to silence earlier diagnostics cc1: note: unrecognized command-line option ‘-Wno-unknow-pragma’ may have been intended to silence earlier diagnostics cc1: all warnings being treated as errors scons: [src/luagoxel.o] Error 1 scons: building terminated because of errors. make: [Makefile:8: release] Error 2 ==> ERROR: A failure occurred in build(). Aborting... Error making: goxel

ax34 commented on 2019-07-18 18:54

I created git version of this pkgbuild: https://aur.archlinux.org/packages/goxel-voxel-editor-git/

tuqueque commented on 2018-08-07 14:58

@tesfabpel Great! Now it works! Thank you very much!

Actually, at first, the program installed fine, but it refused to run. Running it from the Terminal threw the same error @damarusama experienced, so I checked in my Pamac (Pacman) installed software about the "glfw" framework and noticed that I was using the Wayland version of it. I replaced it with the X11 version and voila! It runs now without any issue!

Maybe @damarusama could check the glfw version he/she has installed and make sure to use the X11.

tesfabpel commented on 2018-08-07 13:41

@daneel, @tuqueque sorry for the delay, I've pushed a new release of this package to add the clang=1 option in the Makefile. It should work now.

tuqueque commented on 2018-08-04 17:41

I get this error when trying to install in Manjaro:

https://gist.github.com/tuqueque/e2b43d32f2739abd06f25f777e07ed54

Any ideas?

daneel commented on 2018-05-25 09:00

I get this error: https://github.com/guillaumechereau/goxel/issues/109

Solved by adding sed -i 's/scons debug=0 werror=0/& clang=1/' Makefile before make inside build step.

tesfabpel commented on 2018-04-26 06:40

@damarusama it works for me... Maybe it's an upstream bug? You could try reporting it on the github issues page.

EDIT: Updated the package to v0.8.0. Could you try again with this version?

Thank you.

damarusama commented on 2018-04-25 20:34

I'm getting a:

goxel: /build/glfw/src/glfw-3.2.1/src/monitor.c:394: glfwGetVideoMode: Assertion `monitor != NULL' failed. Aborted (core dumped)

after an install. Not sure how to go about it.