Package Details: gopass-jsonapi-git r6.374b795-1

Git Clone URL: https://aur.archlinux.org/gopass-jsonapi-git.git (read-only, click to copy)
Package Base: gopass-jsonapi-git
Description: The jsonapi for gopass used for bridging to browsers
Upstream URL: https://github.com/gopasspw/gopass-jsonapi
Licenses: MIT
Conflicts: gopass-jsonapi
Provides: gopass-jsonapi
Submitter: sa7dse
Maintainer: sa7dse
Last Packager: sa7dse
Votes: 0
Popularity: 0.000000
First Submitted: 2021-02-12 09:40
Last Updated: 2021-02-13 20:36

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

mipi commented on 2021-02-13 20:55

Thx. That solved the problem.

sa7dse commented on 2021-02-13 20:34

I have updated the package to include the upstream version fix.

muesli commented on 2021-02-12 23:17

The problem is that gopass-jsonapi and gopass's Version strings need to match. In gopass-jsonapi's Makefile the version is retrieved from the VERSION file inside the repo. For some weird reasons that reads 0.0.1. If you set the version to 1.12.0 here, everything starts to work.

Will have to be fixed upstream, I guess. The workaround is temporarily overwriting the version string during packaging.

Also see: https://github.com/gopasspw/gopass-jsonapi/issues/2

mipi commented on 2021-02-12 17:10

Hi, I just install this package after I recognized that gopass-json is no longer part of gopass. I configured gopass-jsonapi for Firefox and Chrome. In both browsers I get the error message "Please update gopass to version 1.8.5 or newer", but my gopass version is 1.12.0. I had the same phenomenon some time ago with gopass which - as far as I remember - was a problem with the package definition. Could you have a look into that? Thanks, mipi