Package Details: google-drive-ocamlfuse 0.7.17-1

Git Clone URL: https://aur.archlinux.org/google-drive-ocamlfuse.git (read-only, click to copy)
Package Base: google-drive-ocamlfuse
Description: FUSE-based file system backed by Google Drive, written in OCaml
Upstream URL: https://astrada.github.io/google-drive-ocamlfuse/
Keywords: drive fuse google ocaml
Licenses: MIT
Submitter: mlq
Maintainer: pricechrispy
Last Packager: pricechrispy
Votes: 57
Popularity: 1.24
First Submitted: 2013-10-14 21:44
Last Updated: 2020-01-21 01:40

Dependencies (7)

Required by (1)

Sources (1)

Pinned Comments

pricechrispy commented on 2018-01-27 00:47

Another error now exists with the camlidl package on a fresh build system.

In this case, the package is no longer creating a required file called "META". This prevents camlidl from showing up as installed, and prevents the package from building.

If you run "ocamlfind list | grep -i 'camlidl'", you should see the camlidl packages listed.

If not, manually create the META file: /usr/lib/ocaml/camlidl/META

description = "Stub generator"
version = "1.06"
directory = "^"
archive(byte) = "com.cma"
archive(native) = "com.cmxa"

pricechrispy commented on 2017-04-25 17:39

Before you flag this package out-of-date:

According to the official project page: https://astrada.github.io/google-drive-ocamlfuse/
Find latest release versions here: https://launchpad.net/~alessandro-strada/+archive/ubuntu/ppa

The latest releases are not all tagged versions on GitHub.
For the latest development versions on git, try: https://aur.archlinux.org/packages/google-drive-ocamlfuse-git

OLD official project page: http://gdfuse.forge.ocamlcore.org/
OLD release versions here: https://forge.ocamlcore.org/frs/?group_id=305

pricechrispy commented on 2016-11-17 10:46

While upgrading to the newer build, the same build error persists as reported in the comments.

When doing a fresh build, I manually created symlinks as root so that the build process finds them, as similarly suggested in the comments.

# ln -s /usr/lib/ocaml/com.cmxa /usr/lib/ocaml/camlidl/
# ln -s /usr/lib/ocaml/com.a /usr/lib/ocaml/camlidl/

After doing this, the directory '/usr/lib/ocaml/camlidl/' should have the following structure in a fresh environment:

$ ls -l /usr/lib/ocaml/camlidl/
total 4
lrwxrwxrwx 1 root root 20 Nov 17 02:23 com.a -> /usr/lib/ocaml/com.a
lrwxrwxrwx 1 root root 23 Nov 17 02:23 com.cmxa -> /usr/lib/ocaml/com.cmxa
-rw-r--r-- 1 root root 102 Nov 17 01:11 META

As suggested in the comments, this seems to be an issue with the camlidl package.

This should allow the package to build for now, until an automated PKGBUILD solution is found.

JP-Ellis commented on 2014-03-04 23:36

Unfortunately, this does not build on its own (@possum has suggested some fixes,but it's a shame that one has to resort to that).

An alternative way to install google-drive-ocamlfuse is through OCaml's package manager OPAM. OPAM can be installed from AUR, and after setting it up, calling "opam install google-drive-ocamlfuse" will install this programme along with the required dependencies. You may have to install other packages which aren't managed by OPAM to meet dependencies and you can find more details at https://github.com/astrada/google-drive-ocamlfuse/wiki/Installation .

lockheed commented on 2014-01-28 15:09

PS
To backup folders form outside the "Copy" folder, just create symbolic links to them.

lockheed commented on 2014-01-15 22:19

The package is fine. The Google Drive itself is the problem.
I have been trying to use it on several account, on very fast internet connections, but it was always the same - the transfer speeds to GDrive are not just low. Oh no. They are absurdly low! I mean in BITS per SECOND! It takes WEEKS to upload mere 20 GB.

Do yourself a favour and create Copy account: https://copy.com?r=cdNDuV
If you use this link, we both get extra 5GB which gives you free 20GB to boot. Unlike google, it is fast, and unlike google they don't ignore linux customers and provide native client.

mlq commented on 2013-12-13 09:37

Apparently you are trying to build ocamlfuse and not google-drive-ocamlfuse, at least the error is happening on the other package. Please state your error there: https://aur.archlinux.org/packages/ocamlfuse/

djringjr commented on 2013-12-13 04:26

Sorry, only half of the errors:

error in building ocamlfuse

^
Fuse_util.c:625:1: note: in expansion of macro ‘FOR_ALL_OPS’
FOR_ALL_OPS(CALLBACK)
^
ar rcs libFuse_stubs.a Fuse_bindings_stubs.o Unix_util_stubs.o Fuse_util.o
ocamlopt -c -thread Result.ml
ocamlopt -c -thread Unix_util.ml
ocamlc -c -thread Fuse_bindings.mli
File "Fuse_bindings.mli", line 37, characters 8-23:
Error: Unbound module Com
../OCamlMakefile:933: recipe for target 'Fuse_bindings.cmi' failed
make[1]: *** [Fuse_bindings.cmi] Error 2
make[1]: Leaving directory '/tmp/packerbuild-0/ocamlfuse/ocamlfuse/src/ocamlfuse-2.7.1-cvs/lib'
../OCamlMakefile:725: recipe for target 'native-code-library' failed
make: *** [native-code-library] Error 2
make: Leaving directory '/tmp/packerbuild-0/ocamlfuse/ocamlfuse/src/ocamlfuse-2.7.1-cvs/lib'
==> ERROR: A failure occurred in build().
Aborting...
The build failed.

djringjr commented on 2013-12-13 04:22

Fuse_util.c:625:1: note: in expansion of macro ‘FOR_ALL_OPS’
FOR_ALL_OPS(CALLBACK)
^
ar rcs libFuse_stubs.a Fuse_bindings_stubs.o Unix_util_stubs.o Fuse_util.o
ocamlopt -c -thread Result.ml
ocamlopt -c -thread Unix_util.ml
ocamlc -c -thread Fuse_bindings.mli
File "Fuse_bindings.mli", line 37, characters 8-23:
Error: Unbound module Com
../OCamlMakefile:933: recipe for target 'Fuse_bindings.cmi' failed
make[1]: *** [Fuse_bindings.cmi] Error 2
make[1]: Leaving directory '/tmp/yaourt-tmp-user/aur-ocamlfuse/src/ocamlfuse-2.7.1-cvs/lib'
../OCamlMakefile:725: recipe for target 'native-code-library' failed
make: *** [native-code-library] Error 2
make: Leaving directory '/tmp/yaourt-tmp-user/aur-ocamlfuse/src/ocamlfuse-2.7.1-cvs/lib'
==> ERROR: A failure occurred in build().
Aborting...

Doesn't work for me today. I want this!

David

mlq commented on 2013-12-05 09:56

I've managed to build it again and updated the PKGBUILD. The only way I was able to make it work is that I've removed all installed packages (and dependencies) of this package and then I rebuilt them from scratch. You need to apply the fixes for 'ocamlfuse' and 'gapi-ocaml' which are both in the comments and you need to install 'ocaml-easy-format' as well which is a dependency of 'ocaml-joyson'.

mlq commented on 2013-12-05 09:38

1) At least the part for camlidl should not be necessary since it seems to detect 'pkg_camlidl' just fine.
2) I've flagged the package out-of-date some time ago, but the maintainer does not react. If nothing happens in the next week I will ask on the mailing list.

I am always running into errors which state 'make inconsistent assumptions over interface Easy_format'. Haven't you experienced them?

possum commented on 2013-12-05 03:52

Installing this package at this moment it's a challenge. I've been able to install it by editing PKGBUILDs only(yaourt saved me a lot of time with this). Here's what i changed:
1) when building ocamlfuse replace in the PKGBUILD the include dirs like this:
make -C lib INCDIRS='/usr/lib/ocaml/stublibs /usr/lib/ocaml/camlidl'
(and not forget 3) )

2) gapi-ocaml says it's 0.2.1 but in fact downloads 0.2, to download the correct version in the PKGBUILD change the url like this:
source=(http://forge.ocamlcore.org/frs/download.php/1274/$pkgname-$pkgver.tar.gz)
and change the checksum to:
md5sums=('c87aa3b2c9afef190307d8da51d65875')
also replace 0.2 with $pkgver in both cd commands.

(and not forget 3) )
NOTE: 2) fixes the error described by @lockheed

3) as said by @calucian, add the option staticlibs with:
options=('staticlibs')
(if options was already present add the new option to the list)
The packages that require staticlibs are:
ocaml-sqlite3, ocaml-extlib, ocaml-cryptokit, ocamlnet, ocaml-curl, gapi-ocaml, camlidl and ocamlfuse

lockheed commented on 2013-12-03 11:07

I am getting this error while compiling. Does anyone know what's happening?
==> Starting build()...
W: Field 'pkg_gapi_ocaml_version_ge_0_2_1' is not set: Cannot satisfy version constraint on pkg_gapi_ocaml: >= 0.2.1 (version: 0.2)
E: Cannot find findlib package gapi-ocaml (>= 0.2.1)
E: Failure("1 configuration error")
==> ERROR: A failure occurred in build().
Aborting...