Package Details: google-drive-ocamlfuse 0.7.13-1

Git Clone URL: https://aur.archlinux.org/google-drive-ocamlfuse.git (read-only, click to copy)
Package Base: google-drive-ocamlfuse
Description: FUSE-based file system backed by Google Drive, written in OCaml
Upstream URL: https://astrada.github.io/google-drive-ocamlfuse/
Keywords: drive fuse google ocaml
Licenses: MIT
Submitter: mlq
Maintainer: pricechrispy
Last Packager: pricechrispy
Votes: 55
Popularity: 0.190485
First Submitted: 2013-10-14 21:44
Last Updated: 2019-10-06 22:53

Dependencies (7)

Required by (1)

Sources (1)

Pinned Comments

pricechrispy commented on 2018-01-27 00:47

Another error now exists with the camlidl package on a fresh build system.

In this case, the package is no longer creating a required file called "META". This prevents camlidl from showing up as installed, and prevents the package from building.

If you run "ocamlfind list | grep -i 'camlidl'", you should see the camlidl packages listed.

If not, manually create the META file: /usr/lib/ocaml/camlidl/META

description = "Stub generator"
version = "1.06"
directory = "^"
archive(byte) = "com.cma"
archive(native) = "com.cmxa"

pricechrispy commented on 2017-04-25 17:39

Before you flag this package out-of-date:

According to the official project page: https://astrada.github.io/google-drive-ocamlfuse/
Find latest release versions here: https://launchpad.net/~alessandro-strada/+archive/ubuntu/ppa

The latest releases are not all tagged versions on GitHub.
For the latest development versions on git, try: https://aur.archlinux.org/packages/google-drive-ocamlfuse-git

OLD official project page: http://gdfuse.forge.ocamlcore.org/
OLD release versions here: https://forge.ocamlcore.org/frs/?group_id=305

pricechrispy commented on 2016-11-17 10:46

While upgrading to the newer build, the same build error persists as reported in the comments.

When doing a fresh build, I manually created symlinks as root so that the build process finds them, as similarly suggested in the comments.

# ln -s /usr/lib/ocaml/com.cmxa /usr/lib/ocaml/camlidl/
# ln -s /usr/lib/ocaml/com.a /usr/lib/ocaml/camlidl/

After doing this, the directory '/usr/lib/ocaml/camlidl/' should have the following structure in a fresh environment:

$ ls -l /usr/lib/ocaml/camlidl/
total 4
lrwxrwxrwx 1 root root 20 Nov 17 02:23 com.a -> /usr/lib/ocaml/com.a
lrwxrwxrwx 1 root root 23 Nov 17 02:23 com.cmxa -> /usr/lib/ocaml/com.cmxa
-rw-r--r-- 1 root root 102 Nov 17 01:11 META

As suggested in the comments, this seems to be an issue with the camlidl package.

This should allow the package to build for now, until an automated PKGBUILD solution is found.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

MokkeMeguru commented on 2019-10-17 23:53

@jdegreef If you got the error like this when you run opam init.

# bwrap: No permissions to creating new namespace, likely because the kernel does not allow non-privileged user namespaces. On e.g. debian this can be enabled with 'sysctl kernel.unprivileged_userns_clone=1'.

I think, your problem is because of kernel version. ref https://github.com/containers/bubblewrap/issues/324

jdegreef commented on 2019-10-17 22:00

@MokkeMeguru I've refused that the install script modify my ./(bash_)profile but as I made everything in the same window it doesn't matter. And you know what ? I knew zero about opanm/ocaml, I just wanted to have google-drive-ocamlfuse running and since a few months using it from aur is a pin in the ass. Today I discovered that opam is a little bit as pip and it don't need Arch packages. But that's off topic ;)

MokkeMeguru commented on 2019-10-17 21:35

@jdegreef Can you check your ~/.bash_profile ? If you tried my solution correctly, Your ~/.bash_profile will have below lines.

# ...
# opam configuration
test -r /home/meguru/.opam/opam-init/init.sh && . /home/meguru/.opam/opam-init/init.sh > /dev/null 2> /dev/null || true

My idea and your idea are nealy the same, I think.

And also, my google-drive-ocamlfuse is installed in /home/meguru/.opam/ocaml-4.09.0/bin/google-drive-ocamlfuse

jdegreef commented on 2019-10-17 20:16

@MokkeMeguru OR, forget about all ocaml Arch packages which are broken at every update, and install ocalm packages from opam (https://opam.ocaml.org/). That's the way I'll follow from now on. Everything is installed into ~/.opam without having any impact on the whole system.

MokkeMeguru commented on 2019-10-16 12:53

Because of https://aur.archlinux.org/packages/ocaml-base/ ,(https://aur.archlinux.org/packages/ocaml-base/#comment-711397) This build is failed.

Please update dependencies ... (or wait a month to update the package ocaml-base)

jdegreef commented on 2019-10-13 18:43

Same problem here in a clean chroot environment.

esturiano commented on 2019-10-12 14:07

File "compiler-stdlib/gen/gen.ml", line 59, characters 33-51: 59 | let toc = (input_value ic : Cmo_format.library) in ^^^^^^^^^^^^^^^^^^ Error: Unbound module Cmo_format File "compiler-stdlib/gen/gen.ml", line 59, characters 33-51: 59 | let toc = (input_value ic : Cmo_format.library) in ^^^^^^^^^^^^^^^^^^ Error: Unbound module Cmo_format

getting this too.

nixit commented on 2019-10-12 03:18

trying to install and am getiting this:

==> Starting build()... File "compiler-stdlib/gen/gen.ml", line 59, characters 33-51: 59 | let toc = (input_value ic : Cmo_format.library) in ^^^^^^^^^^^^^^^^^^ Error: Unbound module Cmo_format ==> ERROR: A failure occurred in build(). Aborting...

any idea.

--nixit

Pfizi commented on 2019-09-16 15:13

Requires gapi-ocaml>=0.3.15, but this is not available yet.

pricechrispy commented on 2019-09-16 03:40

Missing packages were added back to the AUR and the package builds. Updated to latest tagged release. Note this requires gapi-ocaml>=0.3.15