Package Details: google-drive-ocamlfuse-opam 0.7.4-1

Git Clone URL: https://aur.archlinux.org/google-drive-ocamlfuse-opam.git (read-only)
Package Base: google-drive-ocamlfuse-opam
Description: FUSE-based file system backed by Google Drive, written in OCaml (installed from opam)
Upstream URL: https://astrada.github.io/google-drive-ocamlfuse/
Licenses: MIT
Conflicts: google-drive-ocamlfuse
Provides: google-drive-ocamlfuse
Submitter: swordfeng
Maintainer: swordfeng
Last Packager: swordfeng
Votes: 4
Popularity: 0.441172
First Submitted: 2019-02-12 10:25
Last Updated: 2019-05-19 02:03

Required by (1)

  • bups (requires google-drive-ocamlfuse) (optional)

Sources (0)

Latest Comments

swordfeng commented on 2019-07-02 07:31

@thisischrys Just for those who find the other PKGBUILDs not out-of-box and don't care this one running opam update on their behalf.

thisischrys commented on 2019-07-02 06:26

If you do not recommend it, why does it exist? Just curious.

swordfeng commented on 2019-03-10 07:32

@willemw Yes, it would be better to use a VCS name. The problem is, however, it is not using a VCS but the opam package manager to fetch the latest code. So I'm not sure if it makes sense to rename to something like google-drive-ocamlfuse-opam-git.

By the way, I actually do not recommend this PKGBUILD, because it is not clean. It has something to do with the user's environment, though unlikely to break anything (init opam if not initialized and update local package databases).

willemw commented on 2019-03-10 07:17

@swordfeng: forget my "stick to latest releases" comment. I didn't notice this package was a VCS/devel package (has a pkgver() function).

willemw commented on 2019-03-10 07:08

@swordfeng: What you could perhaps do is submit a request to rename this package to google-drive-ocamlfuse-opam-git. Then (some) AUR-helpers will update the package (yay ... --devel, pikaur ... --devel, etc.). No need for you to bump the pkgver= regularly. Also it makes it clear to the user that this is a VCS/devel package.

Note: there is not git source, so this may not work.

swordfeng commented on 2019-03-10 07:04

Oh I maybe misunderstood your comment. Do you mean stick to the stable version but not pre-releases?

swordfeng commented on 2019-03-10 06:58

@willemw Thanks for your comment! I was assuming that no one would use this package given the other two maintained ones. lol

The PKGBUILD itself actually builds the latest version. It's just the version on AUR that may be outdated. I'll try to keep it updated but I cannot always keep an eye on it. You can flag it out-of-date and I'll update.

There's another option: try out the [archlinuxcn] repository. I have it named "google-drive-ocamlfuse" which is in fact this PKGBUILD and updated automatically by a CI.

Edit: typo

willemw commented on 2019-03-10 06:47

0.7.2 and now 0.7.3 are pre-releases. 0.7.1 is the latest release. Maybe stick to latest releases after 0.7.3?