Package Details: google-docs-nativefier 1-3

Git Clone URL: https://aur.archlinux.org/google-docs-nativefier.git (read-only, click to copy)
Package Base: google-docs-nativefier
Description: Electron wrapper for the Google Docs web application
Upstream URL: https://docs.google.com
Licenses: MIT
Submitter: Leo_L
Maintainer: Leo_L
Last Packager: Leo_L
Votes: 1
Popularity: 0.026731
First Submitted: 2019-10-22 20:58
Last Updated: 2020-06-09 21:47

Latest Comments

brody commented on 2020-03-31 12:31

The package is not build able within a clean chroot environment.

Packaging app for platform linux x64 using electron v7.1.11
Error during build. Run with --verbose for details. Error: spawn unzip ENOENT
    at Process.ChildProcess._handle.onexit (internal/child_process.js:267:19)
    at onErrorNT (internal/child_process.js:467:16)
    at processTicksAndRejections (internal/process/task_queues.js:84:21) {
  errno: -2,
  code: 'ENOENT',
  syscall: 'spawn unzip',
  path: 'unzip',
  spawnargs: [
    '-o',
    '/build/.cache/electron/httpsgithub.comelectronelectronreleasesdownloadv7.1.11electron-v7.1.11-linux-x64.zip/electron-v7.1.11-linux-x64.zip',
    '-d',
    '/build/google-docs-nativefier/src/linux-x64-template'
  ],
  cmd: 'unzip -o /build/.cache/electron/httpsgithub.comelectronelectronreleasesdownloadv7.1.11electron-v7.1.11-linux-x64.zip/electron-v7.1.11-linux-x64.zip -d /build/google-docs-nativefier/src/linux-x64-template'
}

Please add the package 'unzip' to the makedepends field to solve the build issue. ;)

Furthermore an updated aur package 'nodejs-nativefier' version 8.0.6 is available. And this version is now based on electron 8.2.0.

So it would great if you adjust the electron parameter from 7.1.11 to 8.2.0 within the PKGBUILD.

Kind regards

Leo_L commented on 2020-03-30 09:09

@dedguy21 Thanks for commenting, i don't use this myself. It works now copied the fix from here https://aur.archlinux.org/packages/google-keep-nativefier/

dedguy21 commented on 2020-03-30 00:52

getting an error from google, where it won't let me logon, something about I'm trying to logon from an insecure website...

How do I get around this issue?

...also, is this still being maintained? Not sure had to do too many work arounds to get the package to install properly, and now the Google security message. I use gpmdp for aur, had same message, and the maintainer changed something on the packaging to make it work.

Thank you for any help you can provide...

dedguy21 commented on 2020-03-28 17:36

UPDATE: figured out the package name in the source file is GoogleDocs-linux-x64 and the build is looking for 'google-docs-linux-*', so I simply cp -r GoogleDocs-linux-x64 to google-docs-linux-x64, and the installation went through. Who ever maintains this might want to update the build file.

Thanks


how do i get past the following error in the build process:

'cp: cannot stat 'google-docs-linux-*': No such file or directory'