Package Details: google-chrome-dev 77.0.3854.3-1

Git Clone URL: https://aur.archlinux.org/google-chrome-dev.git (read-only)
Package Base: google-chrome-dev
Description: The popular and trusted web browser by Google (Dev Channel)
Upstream URL: https://www.google.com/chrome
Keywords: chromium
Licenses: custom:chrome
Provides: google-chrome
Submitter: None
Maintainer: luzifer
Last Packager: luzifer
Votes: 630
Popularity: 1.094859
First Submitted: 2009-06-05 21:02
Last Updated: 2019-07-17 19:53

Dependencies (13)

Required by (25)

Sources (3)

Pinned Comments

Det commented on 2016-03-09 05:02

✔ NOTE. If the sha512sums don't match, there's a new version. Simply flag the package.

You can check for new Linux releases in: http://googlechromereleases.blogspot.com/search/label/Stable%20updates, or use:

$ curl -sL https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | tr ' ' '\n' | grep -e name= -e ver= | cut -d '"' -f2 | sed 'N;s/\n/ /'

For new MD5: $ curl -sL https://dl.google.com/linux/chrome/deb/dists/stable/main/binary-amd64/Packages | sed -n '54p'

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

Det commented on 2018-07-28 17:44

Well, I mean I already got a script for updating it, plus I'd rather not skip the MD5. Also instead of:

curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }' | sed -n '/unstable/, +0p' | sed 's/unstable: //g'

you can do just:

curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | grep unstable | cut -d '"' -f10

Or even:

md5sums=("$(curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | grep unstable | cut -d '"' -f2)"
'd50d8f0a6940791eabc41c4f64e6a3cf'
'11b55a3fec7279db32b63e3a0b97dc01')

heavysink commented on 2018-07-28 16:34

This package was maintained by ArchLinux CN(An Unofficial Community Repository).

If you want, you can add lilac as a Co-Maintainer, we will auto update this AUR Repo by the bot.

https://github.com/archlinuxcn/repo/tree/master/google-chrome-dev

Det commented on 2018-01-22 10:05

I got a script for updating (all my packages). I just don't cron it. :d

sanerb commented on 2018-01-22 09:46

hey det, would it help you avoid unnecessary comments if i write a python script for you that you can cron that'll fetch and parse that .xml.gz and email you if it updates?

Det commented on 2018-01-09 20:07

Your package google-chrome-dev [1] has been flagged out-of-date by gehzumteufel [2]:

I cannot explain why, but the md5sum does not match. Whether via downloading the file directly, or via pacaur. The sum I get is ae421158a6e7268c313150b8fff6c2a0. Which does not match any of the sums in the pkgbuild.

Because there is a new version, as per the instructions in the pinned comment.

Det commented on 2018-01-04 23:20

staticfloat flagged google-chrome-dev out-of-date on 2018-01-04 for the following reason:

md5 checksums out of date

No it isn't.

denixx commented on 2017-11-29 13:34

@dsifford Thanks for suggestion, though. :)

denixx commented on 2017-11-29 13:31

@dsifford
Line 47 of PKGBUILD:
install -Dm644 "$pkgdir"/opt/google/chrome-$_channel/product_logo_${i/x*}-${pkgname/*-}.png \

between ${i/x*}-${pkgname/*-}
change minus to underscore:
${i/x*}_${pkgname/*-}

like this:
install -Dm644 "$pkgdir"/opt/google/chrome-$_channel/product_logo_${i/x*}_${pkgname/*-}.png \

dsifford commented on 2017-11-29 01:32

Error in latest build:

install: cannot stat '/home/dsifford/.cache/pacaur/google-chrome-dev/pkg/google-chrome-dev/opt/google/chrome-unstable/product_logo_16.png': No such file or directory

Looking in the directory specified above, it looks like chrome is now appending "_dev" after the number.. So, in the above case, it would be "product_logo_16_dev.png" rather than "product_logo_16.png"...

Looks like that should be a quick fix here: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=google-chrome-dev#n47

Det commented on 2017-11-03 20:06

> lytedev flagged google-chrome-dev out-of-date on 2017-11-02 for the following reason:
>
> Failing checksum; flagging as requested.

Matches just fine for me.