Package Details: goobook-git 3.5.1-2

Git Clone URL: https://aur.archlinux.org/goobook-git.git (read-only, click to copy)
Package Base: goobook-git
Description: Search your google contacts from the command-line or mutt.
Upstream URL: https://gitlab.com/goobook/goobook
Licenses: GPL
Conflicts: goobook
Provides: goobook
Submitter: firecat53
Maintainer: firecat53
Last Packager: firecat53
Votes: 58
Popularity: 0.002691
First Submitted: 2010-03-29 18:20
Last Updated: 2021-03-15 02:18

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8

firecat53 commented on 2010-10-19 17:58

Updated to reflect python2 dependency. Note -- until python-argparse is fixed, you have to change the depends line in that PKGBUILD to python2 (instead of python<2.7).

firecat53 commented on 2010-08-16 16:25

Added python-keyring dependency.

ejstacey commented on 2010-08-16 01:34

Just an FYI, this also requires python-keyring >= 0.2.

anpieber commented on 2010-04-23 06:02

seams to work fine. Thank you very much!

firecat53 commented on 2010-04-23 00:25

1. Added python-hcs_utils package to AUR (version 1.1.1)
2. Patched (temporarily, until python-argparse is updated) goobook source to only require argparse 1.0.1. I tested goobook and it seems to work with the lower version of argparse, but let me know if I'm wrong!

Scott

firecat53 commented on 2010-04-23 00:14

1. Added hcs_utils package to AUR (version 1.1.1)
2. Patched (temporarily, until python-argparse is updated) goobook source to only require argparse 1.0.1. I tested goobook and it seems to work with the lower version of argparse, but let me know if I'm wrong!

Scott

anpieber commented on 2010-04-22 07:44

ah ok found the required version: http://pypi.python.org/pypi/hcs_utils/1.0rc1

anpieber commented on 2010-04-22 07:31

ok, i know that always the latest version is used; but this case is different. Some additional references are required:

1) python-argparse (http://aur.archlinux.org/packages.php?ID=26000); but the package is in a lower version (1.0.1) than required by goobook (1.1). Nevertheless goobook also works with 1.0.1; I've flagged the python-argparse package out of date. We can wait for the python-argparse maintainer to upgrade his package or talk to the goobook maintainer to use the >1.0 version in the requirements

2) hcs_utils (git://gitorious.org/hcs_utils/mainline.git) Currently there is no aur package available for this reference. Besides two problems again: 1) version numbers do not match (1.0 in hcs_utils; 1.0rc1 required by goobook). 2) I'm no python expert and have no idea why this happen (I find nothing within the setup.py which can cause this behavior), but if i use sudo python setup.py install it produces a hcs_utils of version x.x.dev. Any ideas how I can get rid of it? @1) I'm going to write to the goobook mailing list @2) no idea, sry; otherwise I'll provide the hcs_utils package on my own

kind regards