Package Details: goland-eap 211.6693.76-1

Git Clone URL: https://aur.archlinux.org/goland-eap.git (read-only, click to copy)
Package Base: goland-eap
Description: Capable and Ergonomic Go IDE
Upstream URL: https://www.jetbrains.com/go/
Licenses: custom:jetbrains
Conflicts: gogland-eap
Replaces: gogland-eap
Submitter: freswa
Maintainer: freswa
Last Packager: freswa
Votes: 15
Popularity: 0.009944
First Submitted: 2017-11-02 17:52
Last Updated: 2021-04-03 15:07

Dependencies (3)

Required by (0)

Sources (3)

Latest Comments

1 2 3 Next › Last »

freswa commented on 2021-02-26 22:28

@navarroaxel It's fixed in the latest eap.

navarroaxel commented on 2021-02-19 11:42

Did you see my comment about how to fix the goland-eap command? Because this new release has the same bug https://aur.archlinux.org/packages/goland-eap#comment-791465

navarroaxel commented on 2021-02-13 19:30

The command is not working:

$ goland-eap 
Error: Could not find or load main class com.intellij.idea.Main

The error comes from this line in PKGBUILD:

ln -s "/opt/${pkgbase}/bin/${pkgbase%-eap}.sh" "${pkgdir}/usr/bin/${pkgbase}"

You should create a wrapper script instead of symlink to /opt/goland-eap/bin/goland.sh to fix this issue.

The goland-eap command should be a file with this content:

#!/bin/bash
exec /opt/goland-eap/bin/goland.sh "$@"

check https://aur.archlinux.org/cgit/aur.git/commit/?h=webstorm-eap&id=dc8cbeca5039a6125ce73ccb4ccc0c3d75a1becf

f1x commented on 2021-01-18 08:29

This diff (at least for the current version) fixes the broken paths:

$ git diff PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index f4bb64c..a880892 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@

 pkgbase=goland-eap
 pkgname=(goland-eap goland-eap-jre)
-pkgver=203.6682.75
+pkgver=2020.3.1
 pkgrel=1
 pkgdesc='Capable and Ergonomic Go IDE'
 arch=('x86_64' 'i686')
@@ -13,7 +13,7 @@ options=('!strip')
 source=("https://download.jetbrains.com/go/${pkgbase%-eap}-${pkgver}.tar.gz"
         jetbrains-goland-eap.desktop
         LICENSE)
-b2sums=('db9adb7d5cd327bff0ce20336b672276b3c592ae8cce5807ae17337fbcb2f9a4f7f8c07b46c53ab4ef0e7f8b2df93c1327f2d754645e80a8a38f666ebd6894a7'
+b2sums=('71e9cd673a4503e4a2e7f295be8302be081a323a7694e237e4155763f2d2ae6dd9e77fb2603860482c72abfee54456607a67952f64ffcd02197e7bc9659cd44d'
         'b985586e25598fbe87d697403e87ed45f8ce7b944e6d3ba02509f4c6f2544e3b7a55f19861d399dadcae699db894d3f2be73039401ac004370115f3cefc1fe9c'
         'dadaf0e67b598aa7a7a4bf8644943a7ee8ebf4412abb17cd307f5989e36caf9d0db529a0e717a9df5d9537b10c4b13e814b955ada6f0d445913c812b63804e77')

Maybe the versioning changed on jetbrains side.

seyfert commented on 2021-01-14 03:30

Couldn't stat GoLand-203.6682.75 when update to goland-eap 203.6682.75-1

cp: cannot stat '/home/$/.cache/yay/goland-eap/src/GoLand-203.6682.75/': No such file or directory
==> ERROR: A failure occurred in package_goland-eap().
    Aborting...
error making: goland-eap

but find goland files in src, directory name seems not excepted as we want

⋊> ~/.c/y/g/src on master ◦ ls                                                                                                                                                                                                 11:26:17
GoLand-2020.3.1/  goland-203.6682.75.tar.gz@  jetbrains-goland-eap.desktop@  LICENSE@

petris commented on 2020-11-29 19:54

Update to 203.5981.98-1 does not build properly.

==> Extracting sources...
  -> Extracting goland-203.5981.98.tar.gz with bsdtar
==> Entering fakeroot environment...
==> Starting package_goland-eap()...
cp: cannot stat '/builds/arch-linux/packages-proprietary/goland-eap/src/GoLand-203.5981.98/': No such file or directory
==> ERROR: A failure occurred in package_goland-eap().
    Aborting...
ERROR: Job failed: exit code 1

navarroaxel commented on 2020-07-31 07:59

Hi @freswa, you shouldn't rollback to a previous version (see https://wiki.archlinux.org/index.php/PKGBUILD#epoch).

Also, if you check the https://snapcraft.io/goland page, JetBrains publish the latest build, stable or EAP, to the "latest/edge" channel (command: snap install goland --edge --classic). So, you should always publish the latest build in this package. Atm, I'm talking about build 202.6397.65 version 2020.2 stable.

anatolik commented on 2020-07-23 21:38

==> Starting package_goland-eap()... cp: cannot stat '/build/goland-eap/src/GoLand-202.6397.65/': No such file or directory

anatolik commented on 2020-06-06 03:49

It fails to build:

==> Starting package_goland-eap()... cp: cannot stat '/build/goland-eap/src/GoLand-2020.1/': No such file or directory ==> ERROR: A failure occurred in package_goland-eap(). Aborting... ==> ERROR: Build failed, check /var/lib/archbuild/local-x86_64/anatol/build

RubenKelevra commented on 2020-04-03 16:33

The update doesn't work, the folder is now named "GoLand-2020.1" not "GoLand-201.6668.63".

I recommend a temporary move, since the version layout is probably changing again after this version?