Package Details: gog-thimbleweedpark 1:1.0.958.19330-1

Git Clone URL: https://aur.archlinux.org/gog-thimbleweedpark.git (read-only)
Package Base: gog-thimbleweedpark
Description: Thimbleweed Park
Upstream URL: https://www.gog.com/game/thimbleweed_park
Licenses: custom
Submitter: Auerhuhn
Maintainer: Auerhuhn
Last Packager: Auerhuhn
Votes: 1
Popularity: 0.000000
First Submitted: 2017-08-12 11:35
Last Updated: 2018-03-22 19:21

Latest Comments

P0rtn0yz commented on 2018-04-20 21:13

Failure while downloading gogdownloader://thimbleweed_park/en3installer0

Found nothing in https://api.gog.com/downloader2/installer/thimbleweed_park/en3installer0/

Auerhuhn commented on 2018-03-22 19:23

Thanks @Hoek for bringing this to my attention.

You are correct. The sha512sum has changed because upstream has updated from 1.0.938.14433 to 1.0.958.19330. Fixed the hash, thanks!

Hoek commented on 2018-03-18 15:39

Seems like the file thimbleweed_park_en_1_0_938_14433.sh now has a changed sha512sum.

Previously: 2db274b477307efaecd4bbc2e1916fb833b12b9f3615cce217dea3aa4995576dd1fdd26ea012f2ff12f959743b1176e04fa5d1508699f0f42bd53a97f5119125

Now: 93970bcfca4d201abf5858559f0fe33d2d3e18930d10e1c6e1691fee1075d82f5e6f6b51b0200d55276ce1546308ffc8ad9db5bbb5185af90f2caf092a4adf05

WhyNotHugo commented on 2017-10-08 00:10

Perfect, thanks!

Auerhuhn commented on 2017-10-07 23:54

Thanks a lot for your contribution @WhyNotHugo! I gave it a few test runs and it seems to work very well.

I have made a few minor changes:

- Include `lgogdownloader` as a makedep
- Depend on `gcc-libs` instead of `gcc-libs-multilib`
- Re-added epoch to allow upgrading from v2.6.0.7
- Give credits

Thanks once again!

WhyNotHugo commented on 2017-09-19 21:44

Here's an updated PKGBUILD that actually downloads from GOG (or uses a local file if it's already present, which is what PKGBUILD always does):

https://gist.github.com/hobarrera/55bc2fb56008c8a9fd20e7b113d2e911

I added depends as well, which were missing.

I also replaced "Installing" with "Packaging" in the PKBGUILD output, since that's what it actually does.

WhyNotHugo commented on 2017-08-28 13:59

Ah, I didn't pay attention to that. The gog website does specify the version though. Maybe it's the installer version? Odd though.

As for using the local file: if the file is present, makepkg won't try to download it and will use the local copy, so nothing fancy required for that to work (you might want to check the example one I posted).

Auerhuhn commented on 2017-08-28 07:23

> Why is this version 2.6.0.7? 1.0.938 was released recently.

@hobarrera The file name of the installer was `gog_thimbleweed_park_2.6.0.7.sh`. Lacking other information, I had assumed 2.6.0.7 was the game version.
I have updated the package. Thank you for pointing out the new upstream release.

> Would you mind updating this package to use lgogdownloader […]?

I have looked into it, and plan to add support. What I’m still trying to figure out is how to support either option in the same PKGBUILD: the local installer and the protocol.

WhyNotHugo commented on 2017-08-26 19:45

Why is this version 2.6.0.7? 1.0.938 was released recently.

WhyNotHugo commented on 2017-08-21 02:33

Would you mind updating this package to use lgogdownloader (https://aur.archlinux.org/packages/gog-darkest-dungeon/ might help as a reference)?