Package Details: gobject-introspection-git 1:1.45.2.3354.fb91f7e-1

Git Clone URL: https://aur.archlinux.org/gobject-introspection-git.git (read-only)
Package Base: gobject-introspection-git
Description: GObject Introspection
Upstream URL: http://live.gnome.org/GObjectIntrospection/
Licenses: GPL, LGPL
Conflicts: gobject-introspection, gobject-introspection-runtime, gobject-introspection-svn
Provides: gobject-introspection=1.45.2.3354.fb91f7e, gobject-introspection-runtime=1.45.2.3354.fb91f7e
Replaces: gobject-introspection-svn
Submitter: mrspin
Maintainer: None
Last Packager: lubosz
Votes: 54
Popularity: 0.742882
First Submitted: 2009-02-13 18:40
Last Updated: 2015-07-02 18:18

Required by (595)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

schneida commented on 2010-11-17 12:08

I also needed to export PYTHON=/usr/bin/python2 before running makepkg...

Anonymous comment on 2010-11-16 21:17

please change in PKGBUILD python -> python2, failed for me with python 3.1 with error:

checking for headers required to compile python extensions... File "<string>", line 1
import sys; print sys.prefix
^
SyntaxError: invalid syntax
File "<string>", line 1
import sys; print sys.exec_prefix
^
SyntaxError: invalid syntax
not found
configure: error: Python headers not found

Anonymous comment on 2010-10-30 23:52

Cannot replace gobject-introspection with gobject-introspection-git. The following conflict occurs:

error: failed to prepare transaction (could not satisfy dependencies)
:: pygobject: requires gobject-introspection>=0.9.6

pygobject refuses to use the new version

Anonymous comment on 2010-10-30 19:54

lubosz lines works. Please update PKGBUILD with these lines.

Anonymous comment on 2010-10-29 13:05

Doesn't build after the Python2/Python3 switch

checking for headers required to compile python extensions... File "<string>", line 1
import sys; print sys.prefix
^
SyntaxError: invalid syntax
File "<string>", line 1
import sys; print sys.exec_prefix

Anonymous comment on 2010-10-27 15:49

please update PKGBUILD with the lines from lubosz

lubosz commented on 2010-10-07 16:11

Wrong again. export IS needed.

http://paste.pocoo.org/show/272308/

lubosz commented on 2010-10-07 15:53

I was wrong. It has to be an absolute path (export also is not needed):

PYTHON=/usr/bin/python2

Also, autogen runs configure automatically, so pass the arguments to autogen, and don't run configure explicitly:

./autogen.sh --prefix=/usr || return 1

Working pkgbuild:
http://aur.pastebin.com/xckgUdNe

lubosz commented on 2010-10-07 15:28

This simple line fixes the build:
export PYTHON=python2

The whole pkgbuild:
http://aur.pastebin.com/S9T5M8Qg

lubosz commented on 2010-10-07 15:15

This does not build since the python3 transition.