Package Details: gobject-introspection-git 1:1.45.2.3354.fb91f7e-1

Git Clone URL: https://aur.archlinux.org/gobject-introspection-git.git (read-only)
Package Base: gobject-introspection-git
Description: GObject Introspection
Upstream URL: http://live.gnome.org/GObjectIntrospection/
Licenses: GPL, LGPL
Conflicts: gobject-introspection, gobject-introspection-runtime, gobject-introspection-svn
Provides: gobject-introspection=1.45.2.3354.fb91f7e, gobject-introspection-runtime=1.45.2.3354.fb91f7e
Replaces: gobject-introspection-svn
Submitter: mrspin
Maintainer: lubosz
Last Packager: lubosz
Votes: 53
Popularity: 0.000000
First Submitted: 2009-02-13 18:40
Last Updated: 2015-07-02 18:18

Required by (589)

Sources (1)

Latest Comments

1 2 3 Next › Last »

shoober420 commented on 2019-08-22 04:46

Whoops, I accidentally did a double request. I didn’t even know that was a thing.

lubosz commented on 2015-07-02 15:45

updated git build to pacman 4, added gobject-introspection-runtime to conflicts

https://gist.github.com/lubosz/32ec14606d51d6d71a4a

lubosz commented on 2014-06-22 11:50

Could you please update the package to pacman 4:

https://gist.github.com/lubosz/c71a168f84474f5dfe3f

haawda commented on 2013-04-21 03:45

Sorry, you are right.

Please have a look at http://paste.pound-python.org/show/32502.

yuyichao commented on 2013-03-17 15:26

@StefanHusmann

Please stop saying that!! I DO use makepkg -S. Again it is pkgbase!!

haawda commented on 2013-03-17 14:55

Same problem as some of your packages:

tar tvf gobject-introspection-git.tar.gz
drwxr-xr-x root/root 0 2013-02-23 22:14 gobject-introspection/
-rw-r--r-- root/root 1736 2013-02-23 22:12 gobject-introspection/PKGBUILD

should be
drwxr-xr-x root/root 0 2013-02-23 22:14 gobject-introspection-git/
-rw-r--r-- root/root 1736 2013-02-23 22:12 gobject-introspection-git/PKGBUILD

Do use use makepkg --source?

Anonymous comment on 2011-06-28 09:41

http://developer.gnome.org/glib/

Only version >= 2.29.7 is the development version.

Therefore you need glib2-git (AUR) to install this one as well.

Anonymous comment on 2011-06-16 04:48

I cannot install the pkg as it depends on 'glib-2.0 >= 2.29.7' but only version 2.28.8 is available.

Anonymous comment on 2011-01-24 13:45

Updated. I'm sorry I took this long but somehow my archlinux loses connection every 30secs to 2 mins.

Anonymous comment on 2011-01-12 12:15

You can also get rid of the || return 1 things, since pacman 3.4 breaks automatically on errors.
You should not use replace for a git package, because you normally use it for a name change, i.e. package B will replace A and A will be removed, since B is the successor of A. Check the wiki, there should be a further explanation, if I am not wrong.