Package Details: gobi-firmware 1-7

Git Clone URL: https://aur.archlinux.org/gobi-firmware.git (read-only, click to copy)
Package Base: gobi-firmware
Description: Firmware for gobi 2000 wwan chipset
Upstream URL: http://www.thinkwiki.org/wiki/Qualcomm_Gobi_2000
Licenses: custom
Submitter: None
Maintainer: eugene
Last Packager: TamCore
Votes: 17
Popularity: 0.000000
First Submitted: 2009-10-05 17:56
Last Updated: 2015-06-08 19:34

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

Nikisch commented on 2012-06-10 21:02

Firmware moved in /usr/lib/firmware/gobi as in 'gobi-loader' package

Nikisch commented on 2012-05-06 17:27

see http://www.thinkwiki.org/wiki/Qualcomm_Gobi_2000

I can't extract .msi in AUR package
You have direct link on UQCN.mbn? upload it into the internet and give me link

my firmwares approach to un2400. you have un2420 modem

antiuser commented on 2012-04-30 19:14

[root@lenarch ~]# /usr/lib/udev/gobi_loader -2000 /dev/ttyUSB0 /lib/firmware/gobi/6
Failed to open tertiary firmware: : No such file or directory
usage: /usr/lib/udev/gobi_loader [-2000] serial_device firmware_dir
[root@lenarch ~]# ls -la /lib/firmware/gobi/6/
итого 12796
drwxr-xr-x 2 root root 4096 мая 1 01:03 .
drwxr-xr-x 13 root root 4096 мая 1 01:03 ..
-rw-r--r-- 1 root root 9523736 мая 1 01:03 amss.mbn
-rw-r--r-- 1 root root 3567308 мая 1 01:03 apps.mbn
[root@lenarch ~]# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 03f0:241d Hewlett-Packard Gobi 2000 Wireless Modem (QDL mode)
Bus 002 Device 002: ID 064e:e201 Suyin Corp. Lenovo Integrated Webcam
[root@lenarch ~]# cat /usr/lib/udev/rules.d/60-gobi.rules |grep 241d
ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="241d", RUN+="gobi_loader -2000 $env{DEVNAME} /lib/firmware/gobi/6"

Nikisch commented on 2012-04-30 17:34

UQCN.mbn why is it needed? everything is working
edit /usr/lib/udev/rules.d/60-gobi.rules (/lib/firmware/gobi/{firmware that you need})

antiuser commented on 2012-04-30 10:04

that package is need to update, gobi-loader doesnt work with this package. its required UQCN.mbn file, that doesnt include to this firmware package.

Nikisch commented on 2012-03-30 11:07

fixed

How extract msi file without wine (msiextract)? Need for update firmware...

Anonymous comment on 2012-03-22 19:46

PKGBUILD needs "noextract=('sp48568.exe')" or the build fails due to bsdtar trying to extract the .exe

Nikisch commented on 2012-01-16 18:38

I edit /etc/udev/rules.d/60-gobi.rules for my device (see lsusb)

*/lib/firmware/gobi" to */lib/firmware/gobi/6" for Generic UMTS (universal, unlocked etc)
other dirs in /lib/firmware/gobi can delete

kbabioch commented on 2011-11-29 23:49

Maybe I've expected too much from this package, but it does "only" grab a package containing the firmware files for you and puts it in the appropriate directory (/lib/firmware/gobi). However you'll still have to find out what of these files you actually need and move/copy/link them, so that the directory /lib/firmware/gobi at least contains the three files "amss.mbn", "apps.mbn" and "UQCN.mbn". In order to find out which of the files you actually need use the following link: http://www.thinkwiki.org/wiki/Qualcomm_Gobi_2000

Considering that the package takes away a big amount of space when you actually don't need most of it, you should probably delete it after taking out the files you need. Alternatively you can still get the firmware out of the driver which comes from the manufacturer. Consider this to be a (last) resort for those of you who can't get access to the files provided by the manufacturer, because it takes also a long amount of time to download as the speed of the server isn't that good - at least for me.

Anyway thanks for the package, was helpful in the end ;).

eworm commented on 2011-01-31 13:31

Please change arch to 'any'! Thanks!