Package Details: gnvim 0.1.6-1

Git Clone URL: https://aur.archlinux.org/gnvim.git (read-only, click to copy)
Package Base: gnvim
Description: GUI for neovim, without any web bloat
Upstream URL: https://github.com/vhakulinen/gnvim
Licenses: MIT
Submitter: Svenstaro
Maintainer: Svenstaro
Last Packager: Svenstaro
Votes: 5
Popularity: 0.31
First Submitted: 2019-05-17 11:31
Last Updated: 2020-07-08 11:14

Latest Comments

caelia commented on 2020-11-13 22:33

@Ataraxy :

Yes, that error indicates that you need to set a default Rust toolchain. I guess you must have rustup installed, so you need to run the command:

rustup default stable

You could also set your default to nightly (or various other less-common values), but gnvim is supposed to compile against stable Rust, so unless you're a Rust developer there is no reason to use anything else.

Also, rustup is a developer tool for managing multiple and/or customized toolchains. It's not hard to use, but one consequence of using it is that you have to manually update your Rust toolchain. If you only ever need stable Rust, you might want to install the rust package instead. That will give you the stable toolchain, which will be updated with Pacman, and you don't have to administer anything.

Ataraxy commented on 2020-10-27 10:01

   Compiling xml-rs v0.8.3
error[E0658]: `cfg(doctest)` is experimental and subject to change
 --> /home/ravi/.cargo/registry/src/github.com-1ecc6299db9ec823/xml-rs-0.8.3/src/lib.rs:9:7
  |
9 | #[cfg(doctest)]
  |       ^^^^^^^
  |
  = note: for more information, see https://github.com/rust-lang/rust/issues/62210

error[E0658]: `cfg(doctest)` is experimental and subject to change
  --> /home/ravi/.cargo/registry/src/github.com-1ecc6299db9ec823/xml-rs-0.8.3/src/lib.rs:13:7
   |
13 | #[cfg(doctest)]
   |       ^^^^^^^
   |
   = note: for more information, see https://github.com/rust-lang/rust/issues/62210

   Compiling base64 v0.12.3
   Compiling pangocairo v0.9.0
   Compiling percent-encoding v1.0.1
error: aborting due to 2 previous errors

For more information about this error, try `rustc --explain E0658`.
error: could not compile `xml-rs`.
warning: build failed, waiting for other jobs to finish...
error: build failed
==> ERROR: A failure occurred in build().
    Aborting...
error making: gnvim

Then:

% rustc --explain E0658
error: no override and no default toolchain set

Is there some default toolchain that is required for build?