Package Details: gnutls-guile 3.6.8-2

Git Clone URL: https://aur.archlinux.org/gnutls-guile.git (read-only)
Package Base: gnutls-guile
Description: A library which provides a secure layer over a reliable transport layer
Upstream URL: https://www.gnutls.org/
Licenses: GPL3, LGPL2.1
Conflicts: gnutls
Provides: gnutls=3.6.8
Submitter: None
Maintainer: Ovsyanka
Last Packager: Ovsyanka
Votes: 0
Popularity: 0.000000
First Submitted: 2019-05-12 07:18
Last Updated: 2019-06-18 20:02

Required by (256)

Sources (2)

Latest Comments

Ovsyanka commented on 2019-06-18 20:03

@jonathon, thank you!

Fixed.

jonathon commented on 2019-06-18 19:45

For conflict resolution to work the provides=() still needs to be versioned, e.g.:

diff --git a/PKGBUILD b/PKGBUILD
index b09f668..fc8b1b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ options=('!zipman')
 depends=('gcc-libs' 'libtasn1' 'readline' 'zlib' 'nettle' 'p11-kit' 'libidn2'
          'libidn2.so' 'libunistring' guile)
 checkdepends=('net-tools')
-provides=($_pkgname)
+provides=($_pkgname=$pkgver)
 conflicts=($_pkgname)
 source=(https://www.gnupg.org/ftp/gcrypt/gnutls/v3.6/${_pkgname}-${pkgver}.tar.xz{,.sig})
 sha256sums=('aa81944e5635de981171772857e72be231a7e0f559ae0292d2737de475383e83'

theYinYeti commented on 2019-06-06 17:41

The conflict seems to be with any version of gnutls, not just one particular version. The conflicts=($_pkgname=$pkgver) line should be more general.