Package Details: gnupg-git 2.2.0+12+g9f5e50e7c-2

Git Clone URL: https://aur.archlinux.org/gnupg-git.git (read-only)
Package Base: gnupg-git
Description: Complete and free implementation of the OpenPGP standard - development
Upstream URL: http://www.gnupg.org/
Licenses: GPL
Conflicts: dirmngr, gnupg, gnupg2
Provides: dirmngr, gnupg=2.2.0+12+g9f5e50e7c
Submitter: alphazo
Maintainer: Alad
Last Packager: TrialnError
Votes: 1
Popularity: 0.000000
First Submitted: 2013-06-30 19:25
Last Updated: 2017-09-20 21:30

Required by (163)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

AdrianCohea commented on 2013-11-29 05:16

Hello, I am having trouble building this package via makepkg -s command. The error comes from the build step on the ./configure file of gnupg. The problem is that libgcrypt is required to be version >=1.6.0, but libgcrypt version is 1.5.3 in core. I could not find a higher version in the Arch repos or AUR.

I propose changing depends to 'libgcrypt>=1.6'. Also, I think this implies a libgcrypt-git package might need to be created in the AUR. (Unfortunately, I don't know how to create packages yet.)

If I figure out how, I will try to make that contribution. Thanks!

AdrianCohea commented on 2013-11-29 05:15

Hello, I am having trouble building this package via makepkg -s command. The error comes from the build step on the ./configure file of gnupg. The problem is that libgcrypt is required to be version >=1.6.0, but libgcrypt version is 1.5.3 in core. I could not find a higher version in the Arch repos or AUR.

I propose changing depends to 'libgcrypt>=1.5'. Also, I think this implies a libgcrypt-git package might need to be created in the AUR. (Unfortunately, I don't know how to create packages yet.)

If I figure out how, I will try to make that contribution. Thanks!

abdo commented on 2013-11-03 22:56

Hi,

You can get rid of the automake-1.11 dependency by fixing configure.ac as follows:

sed -i 's/\[dist-bzip2 no-dist-gzip\]/\[dist-bzip2 no-dist-gzip serial-tests\]/' configure.ac

Also, is there any reason for depending on libassuan-git instead of libassuan from core?

alphazo commented on 2013-08-12 12:39

@Nothing4You, PKGBUILD has been updated. Thanks again.

Nothing4You commented on 2013-08-12 12:30

Also, please remove the replaces=() section. It's reserved for packages replacing obselete packages, not when providing different versions of the same package:
https://wiki.archlinux.org/index.php/PKGBUILD#replaces

Nothing4You commented on 2013-08-12 11:35

Maybe you could send a merge request to the mailing list ( https://mailman.archlinux.org/mailman/listinfo/aur-general ) so gnupg2-git gets merged into this?

alphazo commented on 2013-06-30 19:26

Please use gnupg-git instead that complies with pacman 4.1 PKGBUILD.

alphazo commented on 2013-06-30 19:26

Former package was called gnupg2-git. This one complies with PKGBUILD 4.1 rules. Thanks to @holos for the heavy cleanup.

alphazo commented on 2013-06-30 18:52

Thanks @holos for the heavy cleanup. I have two questions:
- Should I submit the package gnupg-git as you mentioned and then kill gnupg2-git?
- Why is pkgver=2.1.0beta3+220+g82c25e6 considering than it is much newer than the rather old 2.1beta3? What do the extra numbers stand for? When compiled and installed, "gnupg --version" outputs gpg (GnuPG) 2.1.0-beta220. Can version number (220) be automatically appended to the pkgver?

alphazo commented on 2013-06-30 18:39

Thanks @holos for the heavy cleanup. I have two questions:
- Should I submit the package gnupg-git as you mentioned and then kill gnupg2-git?
- Why is pkgver=2.1.0beta3+220+g82c25e6 considering than it is much newer than the rather old 2.1beta3? What do the extra numbers stand for?