Package Details: gnudatalanguage 0.9.9-2

Git Clone URL: https://aur.archlinux.org/gnudatalanguage.git (read-only, click to copy)
Package Base: gnudatalanguage
Description: An IDL (Interactive Data Language) compatible incremental compiler (ie. runs IDL programs)
Upstream URL: https://github.com/gnudatalanguage/gdl
Licenses: GPL
Submitter: Snowman
Maintainer: jankoh
Last Packager: jankoh
Votes: 18
Popularity: 0.000620
First Submitted: 2005-10-19 19:37
Last Updated: 2019-11-07 21:02

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

migueldvb commented on 2016-06-02 19:22

Thanks for figuring out how to fix the compilation problem. I have modified the PKGBUILD and added the available patch until there is a new upstream release.

jwalker commented on 2016-06-02 17:46

I've done some digging and found a workaround. There are two bugs of which the developers are aware and have a patch, and a third which doesn't have a patch. The first two are here:

https://sourceforge.net/p/gnudatalanguage/bugs/686/#9469
https://sourceforge.net/p/gnudatalanguage/bugs/688/#4622

The third bug involves a compatibility issue with HDF5 (https://sourceforge.net/p/gnudatalanguage/bugs/699/). The workaround that I've used is to disable HDF5 (I don't need it) by adding a flag to cmake in the PKGBUILD:

cmake -DCMAKE_INSTALL_PREFIX=/usr -DPYTHON=YES -DPYTHONVERSION=2.7 \
-DPYTHON_EXECUTABLE=/usr/bin/python2.7 \
-DMAGICK=NO -DFFTW=YES -DHDF5=YES -DHDF=NO -DGRIB=YES -DUDUNITS=YES \
-DCMAKE_C_FLAGS="-I/usr/include/ImageMagick \
-I/usr/include/python2.7 \
-I/usr/lib/python2.7/site-packages/numpy/core/include" ..\
-DHDF5=NO

To build the package, do the following. (1) Run makepkg to download and extract the resources. (2) Either wait for the compilation to fail, or cancel it at some point during compilation. (3) Patch the two files with the patches above. (4) Build with the command "makepkg --noextract". The "--noextract" option prevents makepkg from overwriting the patches. I actually used the command "makepkg -sri --noextract".

jwalker commented on 2016-06-01 22:37

Hello, I've run into some errors while compiling. I don't know whether these are due to the packaging or the source itself. Here's the relevant portion of the log:

In file included from /home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/envt.hpp:24:0,
from /home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/FMTIn.hpp:14,
from /home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/FMTIn.cpp:5:
/home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/typedefs.hpp: In member function ‘Guard<T>& Guard<T>::operator=(Guard<T>&)’:
/home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/typedefs.hpp:238:21: error: return-statement with no value, in function returning ‘Guard<T>&’ [-fpermissive]
if( &r == this) return;
^~~~~~
In file included from /home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/datatypes.hpp:499:0,
from /home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/envt.hpp:27,
from /home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/FMTIn.hpp:14,
from /home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/FMTIn.cpp:5:
/home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/specializations.hpp: At global scope:
/home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/specializations.hpp:537:65: error: ‘operator>>’ is not a template function
std::istream& operator>>(std::istream& i, Data_<SpDFloat>& data_);
^
/home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/specializations.hpp:539:66: error: ‘operator>>’ is not a template function
std::istream& operator>>(std::istream& i, Data_<SpDDouble>& data_);
^
/home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/specializations.hpp:541:67: error: ‘operator>>’ is not a template function
std::istream& operator>>(std::istream& i, Data_<SpDComplex>& data_);
^
/home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/specializations.hpp:543:70: error: ‘operator>>’ is not a template function
std::istream& operator>>(std::istream& i, Data_<SpDComplexDbl>& data_);
^
/home/user/aur/gnudatalanguage/src/gdl-0.9.6/src/specializations.hpp:545:67: error: ‘operator>>’ is not a template function
std::istream& operator>>(std::istream& is, Data_<SpDString>& data_);
^
src/CMakeFiles/gdl.dir/build.make:86: recipe for target 'src/CMakeFiles/gdl.dir/FMTIn.cpp.o' failed
make[2]: *** [src/CMakeFiles/gdl.dir/FMTIn.cpp.o] Error 1
CMakeFiles/Makefile2:124: recipe for target 'src/CMakeFiles/gdl.dir/all' failed
make[1]: *** [src/CMakeFiles/gdl.dir/all] Error 2
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2

Morn commented on 2016-01-27 18:15

Thanks, that was fast! :-)

migueldvb commented on 2016-01-27 17:22

Sorry about the missing docs directory. It has been fixed in 0.9.6-2.

Morn commented on 2016-01-27 17:09

There is an error during packaging:

==> Making package: gnudatalanguage 0.9.6-1 (Wed Jan 27 18:07:15 CET 2016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Removing existing $pkgdir/ directory...
==> Entering fakeroot environment...
==> Starting package()...
[ 16%] Built target antlr
[100%] Built target gdl
[100%] Built target symlink_gdl
Install the project...
-- Install configuration: "Release"
-- Installing: /home/martin/aur/gnudatalanguage/pkg/gnudatalanguage/usr/share/gnudatalanguage/AUTHORS
-- Installing: /home/martin/aur/gnudatalanguage/pkg/gnudatalanguage/usr/share/gnudatalanguage/README
CMake Error at cmake_install.cmake:59 (file):
file INSTALL cannot find
"/home/martin/aur/gnudatalanguage/src/gdl-0.9.6/doc/gdl.1".


Makefile:71: recipe for target 'install' failed
make: *** [install] Error 1
==> ERROR: A failure occurred in package().
Aborting...

dwysocki commented on 2015-09-05 03:03

migueldvb: Excellent, it builds successfully now. Thank you!

migueldvb commented on 2015-09-03 17:58

dwysocki: I have included a dependency on an older version of the plplot library that fixes this problem.

dwysocki commented on 2015-08-26 22:02

The build is still failing for me, due to the issue with plplot.

Looking at some of the comments here, it seems there's a patch. Was that incorporated into the package already, or do I need to do something for that?

The exact error is:

-- Could NOT find PLPLOT (missing: PLPLOT_LIBRARIES)
CMake Error at CMakeLists.txt:363 (message):
plplot library is required but was not found.

Use -DPLPLOTDIR=DIR to specify the plplot directory tree.

(suitable Debian/Ubuntu packages: libplplot-dev,
[plplot9-driver-xwin])(suitable Fedora package: plplot-devel)


-- Configuring incomplete, errors occurred!
See also "/tmp/packerbuild-1000/gnudatalanguage/gnudatalanguage/src/gdl-0.9.5/build/CMakeFiles/CMakeOutput.log".
See also "/tmp/packerbuild-1000/gnudatalanguage/gnudatalanguage/src/gdl-0.9.5/build/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().
Aborting...
The build failed.

migueldvb commented on 2015-08-26 15:59

Thanks for the report of netcdf cxx legacy library missing package. This release of gdl can be build with netcdf-cxx