Package Details: gnudatalanguage 0.9.9-2

Git Clone URL: https://aur.archlinux.org/gnudatalanguage.git (read-only, click to copy)
Package Base: gnudatalanguage
Description: An IDL (Interactive Data Language) compatible incremental compiler (ie. runs IDL programs)
Upstream URL: https://github.com/gnudatalanguage/gdl
Licenses: GPL
Submitter: Snowman
Maintainer: jankoh
Last Packager: jankoh
Votes: 18
Popularity: 0.000563
First Submitted: 2005-10-19 19:37
Last Updated: 2019-11-07 21:02

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

jankoh commented on 2018-09-06 10:58

Hey @migueldvb,

you removed the patch, now there's the build error the patch was needed for:

Scanning dependencies of target gdl [ 16%] Building CXX object src/CMakeFiles/gdl.dir/CFMTLexer.cpp.o [ 17%] Building CXX object src/CMakeFiles/gdl.dir/FMTIn.cpp.o In file included from /home/jankoh/.cache/yay/gnudatalanguage/src/gdl-0.9.8/src/str.hpp:25, from /home/jankoh/.cache/yay/gnudatalanguage/src/gdl-0.9.8/src/envt.hpp:26, from /home/jankoh/.cache/yay/gnudatalanguage/src/gdl-0.9.8/src/FMTIn.hpp:14, from /home/jankoh/.cache/yay/gnudatalanguage/src/gdl-0.9.8/src/FMTIn.cpp:5: /home/jankoh/.cache/yay/gnudatalanguage/src/gdl-0.9.8/src/basegdl.hpp:27:12: schwerwiegender Fehler: rpc/rpc.h: Datei oder Verzeichnis nicht gefunden # include <rpc rpc.h=""> ^~~~~~~~~~~ Kompilierung beendet. make[2]: [src/CMakeFiles/gdl.dir/build.make:76: src/CMakeFiles/gdl.dir/FMTIn.cpp.o] Fehler 1 make[1]: [CMakeFiles/Makefile2:130: src/CMakeFiles/gdl.dir/all] Fehler 2 make: *** [Makefile:141: all] Fehler 2 ==> FEHLER: Ein Fehler geschah in build(). Breche ab... Error making: gnudatalanguage</rpc>

I still can send you the correct version of the patch, just write me a message where to put it...

Best regards Jan

jankoh commented on 2018-08-18 11:13

Hey there,

could you remove the first "+"'s in every line in gdl-tirpc.patch? That was meant as a patch to the repository, not to gdl. :)

Best regards Jan

jankoh commented on 2018-08-05 20:10

Building fails at the moment due to glibc-update (see [1]).

I created a patch for upgrading to 0.9.8 and fixing the build error, that I can provide.

Best regards Jan

[1] https://github.com/gnudatalanguage/gdl/pull/338

migueldvb commented on 2017-02-08 20:32

@Universebenzene thanks for the report. The error has been fixed in 0.9.7-3

Universebenzene commented on 2017-02-08 04:50

An error occurred when building the new 0.9.7 version:

make[2]: *** [src/CMakeFiles/gdl.dir/build.make:735: src/CMakeFiles/gdl.dir/dialog.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:125: src/CMakeFiles/gdl.dir/all] Error 2
make: *** [Makefile:139: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build gnudatalanguage.

Any body met this problem?

James-T commented on 2017-01-18 10:42

Not sure of the origin of this message, which shows when I start gdl:
10:33:08: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8).

It occurs on the two Manjaro boxes where I have GDL installed, it doesn't seem to cause any problems of functionality, but it would be nice to know what is causing it.

Universebenzene commented on 2016-06-07 03:32

Well the -DHDF5 should be NO, or compiling will fail. Thanks georgeg and migueldvb.

migueldvb commented on 2016-06-06 20:56

Thanks georgeg, I have included those patches in the PKGBUILD.

georgeg commented on 2016-06-06 20:20

I compiled it successfully from yaourt by adding a prepare() to PKGBUILD to apply the patches and also changing -DHDF5=Yes to -DHDF5=No

https://bpaste.net/show/c99e313cb2ef

Universebenzene commented on 2016-06-03 02:42

Hello, when I use yaourt to build the new version of gdl, several error occured:
https://bpaste.net/show/a441b1ad3242

Any ideas?