Package Details: gnudatalanguage 0.9.9-2

Git Clone URL: https://aur.archlinux.org/gnudatalanguage.git (read-only, click to copy)
Package Base: gnudatalanguage
Description: An IDL (Interactive Data Language) compatible incremental compiler (ie. runs IDL programs)
Upstream URL: https://github.com/gnudatalanguage/gdl
Licenses: GPL
Submitter: Snowman
Maintainer: jankoh
Last Packager: jankoh
Votes: 18
Popularity: 0.000563
First Submitted: 2005-10-19 19:37
Last Updated: 2019-11-07 21:02

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

jankoh commented on 2019-01-25 00:29

New update featuring:

  • switch back to plplot510 (updated) (see comment by James-T)

  • changes deps from grib_api to eccodes

  • fixed comiler warnings

jankoh commented on 2019-01-19 22:22

@ego: Thanks, I'll have a look into it.

ego commented on 2019-01-19 13:53

Please replace the dependency of grib_api by eccodes, which should be in general the replacement for grib_api

jankoh commented on 2019-01-16 22:52

@Universebenzene: I prepared a patch for plplot510, so it can cmake against recent a version. Though I must admit, the check itself sems to be broken, since it uses cmake internals...

I asked migueldvb for permission to push the change in plplot.patch over there.

Best Jan

Universebenzene commented on 2019-01-13 15:56

Actually the reason why I changed the depends to plplot is that the plplot510 can't compile on my PCs(I have two PCs with Arch Linux installed)... Maybe I should ask the maintainer of plplot510 about that. Thanks to @James-T anyway.

jankoh commented on 2019-01-13 12:20

@James-T: Thanks for pointing that out. I'm not sure we can get plplot packaged with that option enabled, but I'll comment there citing the README file.

Thanks again, Jan

James-T commented on 2019-01-08 16:12

Now that the package has been updated to use the current version of plplot, a useful hint that is hidden in the depths of the readme file (and couched in more Ubuntuish terms).

When building plplot, add the following line to the cmake options in the PKGBUILD file: -DOLD_WXWIDGETS:BOOL=ON \

without that draw widgets won't work.

Universebenzene commented on 2018-12-16 05:20

It's so sad that this package is orphaned now...

jankoh commented on 2018-12-01 00:10

If this package still is maintained:

Please find a patch at [1] and apply it to the git repository (current master) using "git apply gnudatalanguage.patch".

I tested using makepkg/install the package, and running it. So far everything is working.

[1] https://drive.google.com/file/d/12E0Wa6ZlvBTij8bshRCY_BobVzA_tvpd/view?usp=sharing

Best regads, Jan

georgeg commented on 2018-11-05 19:56

This is still broken, so here is a link to a version of the package that actually works (for me, at least) for anybody interested.

https://github.com/georgegeddes/aur-gdl