Package Details: gns3-gui 2.2.5-1

Git Clone URL: https://aur.archlinux.org/gns3-gui.git (read-only, click to copy)
Package Base: gns3-gui
Description: GNS3 network simulator. Graphical user interface package.
Upstream URL: https://github.com/GNS3/gns3-gui
Licenses: GPL3
Groups: gns3
Submitter: korjjj
Maintainer: buzo
Last Packager: buzo
Votes: 71
Popularity: 0.072354
First Submitted: 2014-05-13 18:56
Last Updated: 2020-01-13 17:39

Dependencies (15)

Required by (2)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

taca commented on 2017-05-11 20:41

Hello,

Just in case, the commented out substitution in the PKGBUILD prepare should now be run on "requirements.txt", not "setup.py".

I also had an issue with gui scaling. Apparently High DPI is enabled by virtue of having QT and PyQT version 5.6 or above. I don't have a high DPI screen, but I do have QT 5.8.

So I commented out lines 36-39 of gns3/application.py which fixed that particular problem.

Regards,

alexanderp commented on 2017-05-10 12:23

Ok hcartiaux. I'll check back on Monday then.

hcartiaux commented on 2017-05-09 13:23

@alexanderp I will not have the time before this week-end.
I can add you to the co-maintainer list if you want.

alexanderp commented on 2017-05-09 12:37

1. This package is in dire need of an update.
2. Replace dependency to gns3-net-converter with gns3-converter

hcartiaux, do you have the time to maintain this package?

Yann.O commented on 2017-04-13 08:19

Using this package at version "1.5.3", after running `gns3server` I was struck with the same error when trying to run the `gns3` client :

```
Traceback (most recent call last):
File "/usr/bin/gns3", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.6/site-packages/pkg_resources/__in
it__.py", line 3036, in <module>
@_call_aside
File "/usr/lib/python3.6/site-packages/pkg_resources/__in
it__.py", line 3020, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/pkg_resources/__in
it__.py", line 3049, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.6/site-packages/pkg_resources/__in
it__.py", line 654, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.6/site-packages/pkg_resources/__in
it__.py", line 968, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.6/site-packages/pkg_resources/__in
it__.py", line 854, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'gns3-net-converter
>=1.3.0' distribution was not found and is required by gns3
-gui

```

I solved it by installing the python module in userspace :
`pip install --user gns3-net-converter`

astroboy589 commented on 2017-03-03 09:10

+1 for munzirtaka. I get the same thing.

munzirtaha commented on 2017-02-09 22:08

~> gns3
Traceback (most recent call last):
File "/usr/bin/gns3", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3030, in <module>
@_call_aside
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3014, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3043, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 654, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 968, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 854, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'gns3-net-converter>=1.3.0' distribution was not found and is required by gns3-gui

~> pacman -Q gns3-net-converter
gns3-net-converter 1.3.0-1

hcartiaux commented on 2017-01-31 08:59

Sorry for the delay, I've updated the PKGBUILD to 1.5.3.

santinas commented on 2017-01-28 09:58

Hi korjjj,

Do you need package maintainer? Please do contact me. Thanks.

enderst commented on 2016-12-21 01:58

Very cool thanks!