Package Details: gnomecast-git r101.e0ec89c-1

Git Clone URL: https://aur.archlinux.org/gnomecast-git.git (read-only, click to copy)
Package Base: gnomecast-git
Description: A native Linux GUI for Chromecasting local files.
Upstream URL: https://github.com/keredson/gnomecast
Licenses: GPL-3.0
Provides: gnomecast
Submitter: mischka
Maintainer: boredland
Last Packager: boredland
Votes: 6
Popularity: 0.006751
First Submitted: 2018-02-16 03:23
Last Updated: 2018-04-24 19:16

Latest Comments

1 2 3 Next › Last »

yochananmarqos commented on 2020-02-19 20:55

The dependencies should be: ffmpeg python-html5lib python-pychromecast python-bottle python-pycaption python-paste python-gobject python-dbus. Pip should NOT be used to install anything as system Python packages will conflict as can be seen by recent comments.

I just added the dependencies to the python-pycaption AUR package. Problem is, it also requires enum34 which is obsolete and gnomecast won't run without python-pycaption.

$ gnomecast 
Traceback (most recent call last):
  File "/usr/sbin/gnomecast", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3254, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3237, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3266, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 584, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 901, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 787, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'enum34' distribution was not found and is required by pycaption

daxid commented on 2019-06-28 11:44

Nearly same here :

Installing collected packages: beautifulsoup4, cssutils, enum34, pycaption, pbr
  Found existing installation: beautifulsoup4 4.7.1
    Uninstalling beautifulsoup4-4.7.1:
Could not install packages due to an EnvironmentError: [Errno 13] Permission non accordée: 'top_level.txt'
Consider using the `--user` option or check the permissions.

I had beautifullsoup installed as root through pip. Installation successful after I removed beautifullsoup from pip !

CaptainJellyfish commented on 2019-04-10 12:54

"Could not install packages due to an EnvironmentError: [Errno 13] No permission: 'dependency_links.txt' Consider using the --user option or check the permissions."

Tried to install manually (cloned with git - in /var/abs/local like mentioned in AUR wiki) - doesn't work though (permissions ok, didn't create a subfolder). This error appears on makepkg, so no "--user" argument available.

Other AUR packages will install just fine.

jleclanche commented on 2019-02-28 22:23

Missing dependency: python-casttube

PedroHLC commented on 2019-02-04 00:27

It also overlaps libpasteurize files with python-future, you should not package this files...

bartus commented on 2019-01-31 21:56

chromecast-git has overlapping files with python-pbr and python-lxml

bartus commented on 2019-01-31 21:41

makedepends is missing git

kriansa commented on 2019-01-03 02:59

There's a dependency missing on default install. You also need AUR python-casttube. Would you add it to the PKGBUILD? Thanks!

bwrsandman commented on 2018-11-22 01:43

Getting an error that the casttube>=0.2.0 dependency is not met. There should be a aur package made for it.

trejjam commented on 2018-10-10 08:17

Hi, can you also add to dependencies python-lxml? Thanks