Package Details: gnome-web-photo 0.10.6-5

Git Clone URL: https://aur.archlinux.org/gnome-web-photo.git (read-only, click to copy)
Package Base: gnome-web-photo
Description: Generate full-size image files and thumbnails from HTML files and web pages
Upstream URL: https://gitlab.gnome.org/Archive/gnome-web-photo
Licenses: LGPL
Submitter: City-busz
Maintainer: PhotonX
Last Packager: PhotonX
Votes: 7
Popularity: 0.000000
First Submitted: 2017-01-26 19:35
Last Updated: 2020-06-04 09:16

Latest Comments

1 2 Next › Last »

PhotonX commented on 2020-06-12 13:03

anonymous352: Please post more output, the lines you posted don't reveal the root of the problem.

PhotonX commented on 2020-06-03 12:48

So in short, it is basically the webkit packages' problem and I shouldn't have put a dependency on any icu version for gnome-web-photo in the first place. I see, thanks! :)

brique commented on 2020-06-03 12:36

Yes, if the webkitgtk-bin package is build against the new icu67 from the official repo, then you can just remove the dependency icu(64) from gnome-web-photo... until the next update of icu ;)

PhotonX commented on 2020-06-03 12:20

Ah, thanks for figuring it out! I used webkitgtk-bin because the non-bin version take so long to compile. Looks like the -bin version is compiled against icu64 then. and a solution would be to ask the webkitgtk-bin packager to fix the icu version in the webkitgtk-bin dependency and remove the icu64 dependency from gnome-web-photo, right?

brique commented on 2020-06-03 11:22

After taking a second look at the error messages i have found the error: It depends on webkitgtk and against which version of icu it is build. After rebuilding webkitgtk, gnome-web-photo builds fine just with the dependency icu from the core repo.

brique commented on 2020-06-02 21:34

@PhotonX: I had nearly the same issue, but the linker error I got was about missing libicui18n.so.65 and libicuuc.so.65. It only builds fine with installed icu65 on my machine.

PhotonX commented on 2020-06-02 21:15

@brique: I tried building it with just icu and it was complaining about missing a libicui18n.so.64 so I guessed, it should be icu64. Also it builds and runs for me with icu64. Why do you think, it should be icu65 rather than 64?

brique commented on 2020-06-02 19:58

Wrong dependency: It needs icu65 to compile and not icu64.

PhotonX commented on 2019-12-24 12:43

yochananmarqos: Updated, thanks for the pointing this out!

yochananmarqos commented on 2019-12-23 21:17

This project is archived, the Upstream URL should be updated: https://gitlab.gnome.org/Archive/gnome-web-photo