Package Details: gnome-vfs-perl 1.082-7

Git Clone URL: https://aur.archlinux.org/gnome-vfs-perl.git (read-only, click to copy)
Package Base: gnome-vfs-perl
Description: Gnome2-VFS perl bindings for gnome-vfs
Upstream URL: http://gtk2-perl.sourceforge.net/
Licenses: LGPL
Submitter: PhotonX
Maintainer: PhotonX (kevr)
Last Packager: PhotonX
Votes: 34
Popularity: 0.130049
First Submitted: 2017-01-25 19:16
Last Updated: 2018-03-03 22:09

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

PhotonX commented on 2019-03-09 17:09

@dark-saber: Sorry for the late reply. I just tried it on my end and though I don't have libselinux installed there is no such error. Do you possibly use some selinux specific packages?

dark-saber commented on 2019-02-28 12:17

@PhotonX: Yes, it does. I've just decided to reinstall gnome-vfs-perl and ran into this issue. And no problem, it's just a small nuisance, but it's interesting that me or somebody else hasn't run into this before.

PhotonX commented on 2019-02-28 11:42

@dark-saber: Does installing libselinux solve the issue? I will look into it asap but most probably not before 8th of March, sorry for the delay!

dark-saber commented on 2019-02-28 11:13

This package should depend on libselinux probably.

rm -f blib/arch/auto/Gnome2/VFS/VFS.so
[ LD blib/arch/auto/Gnome2/VFS/VFS.so ]
chmod 755 blib/arch/auto/Gnome2/VFS/VFS.so
Generating POD...
Can't load 'blib/arch/auto/Gnome2/VFS/VFS.so' for module Gnome2::VFS: libselinux.so.1: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.28/core_perl/DynaLoader.pm line 193.
 at -e line 0.
Compilation failed in require.
BEGIN failed--compilation aborted.
make: *** [Makefile:1351: build/podindex] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
Error making: gnome-vfs-perl

PhotonX commented on 2017-10-02 19:46

Only historical (look further down in the comments). :)

corecode commented on 2017-10-02 19:17

Seems there is a gnome-vfs package that is required by libgnome, etc. Is there any good reason not to depend on gnome-vfs instead of gnome-vfs-nosmb?

PhotonX commented on 2017-06-13 09:00

@philanecros: There is no explicit dependency on perl<5.25, the package builds with perl 5.26 as well. Please post your error output if it doesn't work for you.

PhotonX commented on 2017-03-03 03:19

@JohnRobson: Glad to hear that!

JohnRobson commented on 2017-03-02 23:59

PhotonX, thank you, the problem is solved.

PhotonX commented on 2017-03-01 15:53

@JohnRobson: Did you already check if gtk-doc is installed, as I suggested in my previous comment?