Package Details: gnome-terminal-transparency 3.34.2-1

Git Clone URL: https://aur.archlinux.org/gnome-terminal-transparency.git (read-only, click to copy)
Package Base: gnome-terminal-transparency
Description: The GNOME Terminal Emulator, with background transparency
Upstream URL: https://wiki.gnome.org/Apps/Terminal
Keywords: gnome terminal transparency
Licenses: GPL
Groups: gnome
Conflicts: gnome-terminal
Provides: gnome-terminal=3.34.2
Submitter: hoschi
Maintainer: hoschi
Last Packager: hoschi
Votes: 75
Popularity: 2.60
First Submitted: 2016-04-12 21:23
Last Updated: 2019-10-13 17:48

Required by (11)

Sources (2)

Pinned Comments

hoschi commented on 2017-04-26 15:38

Hi!

This is less invasive than gnome-terminal-fedora, because it doesn't include the notification-feature. Therefore you can stay with the regular vte3 and vte-common! To fullfill the makedepends you probably need to install the packages itstool, docbook-xsl, appstream-glib and yelp-tools, they can be removed when makepkg was executed successfully. Please ensure that you have installed the package group base-devel, which is a requirement to use AUR.

http://i.imgur.com/whZYSLX.png

Top Workaround with devilspie, fore- and background are transparent.

Bottom Background transparency with gnome-terminal, better readability.

@Users of Manjaro

Manjaro usually needs some time to follow Archlinux after major upgrades of GNOME. Please check if Manjaro is providing the same version of GNOME, especially the dependencies vte3 and vte-common. If you want the package for an older release, you can pick the required files from the Git log.

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

hoschi commented on 2017-04-27 09:33

No problem. I've also learned something :)

SunRed commented on 2017-04-27 00:53

@hoschi Curiously enough I did not have pkg-config installed anymore although I do have the base-devel group installed of course. Must've been removed with another package I uninstalled. I did not think about it being a devel package when posting this here. Sorry, my fault then :)

It was already clear no me but nice yet elaborately explained answer. I think this should help others well :)

hoschi commented on 2017-04-26 15:38

Hi!

This is less invasive than gnome-terminal-fedora, because it doesn't include the notification-feature. Therefore you can stay with the regular vte3 and vte-common! To fullfill the makedepends you probably need to install the packages itstool, docbook-xsl, appstream-glib and yelp-tools, they can be removed when makepkg was executed successfully. Please ensure that you have installed the package group base-devel, which is a requirement to use AUR.

http://i.imgur.com/whZYSLX.png

Top Workaround with devilspie, fore- and background are transparent.

Bottom Background transparency with gnome-terminal, better readability.

@Users of Manjaro

Manjaro usually needs some time to follow Archlinux after major upgrades of GNOME. Please check if Manjaro is providing the same version of GNOME, especially the dependencies vte3 and vte-common. If you want the package for an older release, you can pick the required files from the Git log.

hoschi commented on 2017-04-26 11:09

Hello SunRed! You are alive :)
I'm think everything should working automatically and your generally right. So I thought that the package 'pkg-config' has to be part of base-devel and it is. Furthermore adding single packages from 'base-devel' doesn't make much sense, so I thought adding 'base-devel' would make more sense (gcc, make, autotools, patch...). But the Wiki states that 'base-devel' should be generally installed on machines which are using 'makepkg' and packages from 'base-devel' shouldn't be part of makedepends and checkdepends. So this seems to be intended by Archlinux and explains why the offical package also doesn't include pkg-config or base-devel.

https://wiki.archlinux.org/index.php/PKGBUILD#makedepends
'Note: The group base-devel is assumed to be already installed when building with makepkg. Members of this group should not be included in makedepends array.'

https://wiki.archlinux.org/index.php/Makepkg#Usage
'Before continuing, install the base-devel group. Packages belonging to this group are not required to be listed as build-time dependencies (makedepends) in PKGBUILD files. In addition, the base group is assumed to be installed on all Arch systems.'

SunRed commented on 2017-04-26 10:23

Package fails build process without pkg-config package. Would be nice if you add it to makedepends.

hoschi commented on 2017-04-25 22:02

Upgrade on 3.24.1 is available :)

hoschi commented on 2016-11-08 12:30

I will try to care about the new update on 3.22.1 this week.
Maybe I can use the regular source-tarball from upstream instead of git. This will make the build faster and remove a make-dependency.

// edit
Done.

PS: Git is really great! It is just not necessary in this case.

hoschi commented on 2016-10-20 18:31

You can upgrade now :)
Please note: Currently you need "git" as make-dependency.

lucifermstar commented on 2016-10-19 18:34

Any updates on the upgrade?

hoschi commented on 2016-10-17 07:35

I didn't forget it. I'm looking forward to care about the upgrade this week.