Package Details: gnome-terminal-transparency 3.34.2-1

Git Clone URL: https://aur.archlinux.org/gnome-terminal-transparency.git (read-only, click to copy)
Package Base: gnome-terminal-transparency
Description: The GNOME Terminal Emulator, with background transparency
Upstream URL: https://wiki.gnome.org/Apps/Terminal
Keywords: gnome terminal transparency
Licenses: GPL
Groups: gnome
Conflicts: gnome-terminal
Provides: gnome-terminal=3.34.2
Submitter: hoschi
Maintainer: hoschi
Last Packager: hoschi
Votes: 75
Popularity: 2.70
First Submitted: 2016-04-12 21:23
Last Updated: 2019-10-13 17:48

Required by (11)

Sources (2)

Pinned Comments

hoschi commented on 2017-04-26 15:38

Hi!

This is less invasive than gnome-terminal-fedora, because it doesn't include the notification-feature. Therefore you can stay with the regular vte3 and vte-common! To fullfill the makedepends you probably need to install the packages itstool, docbook-xsl, appstream-glib and yelp-tools, they can be removed when makepkg was executed successfully. Please ensure that you have installed the package group base-devel, which is a requirement to use AUR.

http://i.imgur.com/whZYSLX.png

Top Workaround with devilspie, fore- and background are transparent.

Bottom Background transparency with gnome-terminal, better readability.

@Users of Manjaro

Manjaro usually needs some time to follow Archlinux after major upgrades of GNOME. Please check if Manjaro is providing the same version of GNOME, especially the dependencies vte3 and vte-common. If you want the package for an older release, you can pick the required files from the Git log.

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

hoschi commented on 2017-12-08 20:16

I can just guess, but it clearly states that the downloaded sources for gnome-terminal are not valid. Probably they are really ditched? So I would delete 'gnome-terminal-3.26.2.tar.xz' (our just delete everything there) and start over again.

MarkRenshaw commented on 2017-12-08 19:48

I've got this error while installing this!

:: Package gnome-terminal-transparency not found in repositories, trying AUR... :: resolving dependencies... :: looking for inter-conflicts... :: gnome-terminal-transparency and gnome-terminal-git are in conflict (gnome-terminal). Remove gnome-terminal-git? [y/N] y

AUR Packages (1) gnome-terminal-transparency-3.26.2-2

:: Proceed with installation? [Y/n] y :: Retrieving package(s)... :: gnome-terminal-transparency build files are up-to-date -- skipping [sudo] password for amirdadkhah: :: Checking gnome-terminal-transparency integrity... ==> Making package: gnome-terminal-transparency 3.26.2-2 (Fri Dec 8 23:15:02 +0330 2017) ==> Retrieving sources... -> Found gnome-terminal-3.26.2.tar.xz -> Found gnome-terminal-transparency.patch ==> Validating source files with sha256sums... gnome-terminal-3.26.2.tar.xz ... FAILED gnome-terminal-transparency.patch ... Passed ==> ERROR: One or more files did not pass the validity check! :: failed to verify gnome-terminal-transparency integrity

hoschi commented on 2017-11-08 20:45

Please install the package group ‘base-devel’. It is an implicit requirement for using AUR and includes GCC, PATCH and so on.

chris.hamberg commented on 2017-11-08 16:38

[chris@Arch-Linux gnome-terminal-transparency]$ makepkg
==> Making package: gnome-terminal-transparency 3.26.2-2 (Wed Nov 8 10:55:08 EST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found gnome-terminal-3.26.2.tar.xz
-> Found gnome-terminal-transparency.patch
==> Validating source files with sha256sums...
gnome-terminal-3.26.2.tar.xz ... Passed
gnome-terminal-transparency.patch ... Passed
==> Extracting sources...
-> Extracting gnome-terminal-3.26.2.tar.xz with bsdtar
==> Starting prepare()...
/home/chris/gnome-terminal-transparency/PKGBUILD: line 29: patch: command not found
==> ERROR: A failure occurred in prepare().
Aborting...

steadybright commented on 2017-05-09 16:29

Hi Branchard,

I'm running Manjaro, not arch, but I received the same error message. I got around the outdated vte3 problem by installing the vte3-git package instead.

After installing vte3-git, the gnome-terminal-transparency update installed without problem.

I hope this helps you.

sb

branchard commented on 2017-04-27 23:44

Ok Thank you, that works fine !

hoschi commented on 2017-04-27 21:35

In this case you will likely need the old PKGBUILD for 3.22, instead of the current one for 3.24:
https://aur.archlinux.org/cgit/aur.git/snapshot/aur-d474eb8b5491b39f881573b005351da40f37dbc9.tar.gz

I'm looking forward, that this will solve your problem. Probably the internals from gnome-terminal need 3.24 and use some internal number like 'vte-2.91' for the API-Version.

branchard commented on 2017-04-27 20:42

Yea I'm using Gnome 3.22. I'm not able to update vte3 to 0.48, the lastest version on my repos is the 0.46.1.

hoschi commented on 2017-04-27 19:13

Hmm. Awkward error-message! Can you do me a favor and upgrade your vte3 on the current release 0.48. At least, this indicates, you are still using GNOME 3.22. Right?

branchard commented on 2017-04-27 19:02

Hi,
I have the following error:

configure: error: Package requirements (vte-2.91 >= 0.48.2
glib-2.0 >= 2.42.0
gio-2.0 >= 2.34.0
gtk+-3.0 >= 3.12.0
gsettings-desktop-schemas >= 0.1.0
dconf >= 0.14.0
uuid
libpcre2-8 >= 10.00
x11) were not met:

Requested 'vte-2.91 >= 0.48.2' but version of vte is 0.46.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables TERM_CFLAGS
and TERM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.