Package Details: gnome-social-git 0.1.0.r206.1cbaccd-1

Git Clone URL: https://aur.archlinux.org/gnome-social-git.git (read-only, click to copy)
Package Base: gnome-social-git
Description: A Mastodon and Pleroma application for GNOME
Upstream URL: https://gitlab.gnome.org/World/social
Licenses: GPL3
Conflicts: gnome-social
Provides: gnome-social
Submitter: rafaelff
Maintainer: AkechiShiro
Last Packager: AkechiShiro
Votes: 1
Popularity: 0.000256
First Submitted: 2019-09-05 08:44
Last Updated: 2020-12-10 16:20

Pinned Comments

AkechiShiro commented on 2020-12-10 17:47

I added the missing dependency gtk4 but now I need to package libhandy4 merge request branch but I cannot even build the merge request due to some errors in the code, so until the build does actually pass then I'll package it in the AUR I think it is just similar to the libhandy-git package PKGBUILD, the source needs to be changed, and probably other things.

But as long as this repo does not build successfully it is impossible to package libhandy4 unless the merge request actually builds, as of today it doesn't.

Latest Comments

AkechiShiro commented on 2020-12-10 17:47

I added the missing dependency gtk4 but now I need to package libhandy4 merge request branch but I cannot even build the merge request due to some errors in the code, so until the build does actually pass then I'll package it in the AUR I think it is just similar to the libhandy-git package PKGBUILD, the source needs to be changed, and probably other things.

But as long as this repo does not build successfully it is impossible to package libhandy4 unless the merge request actually builds, as of today it doesn't.

rafaelff commented on 2020-11-21 06:30

Social depends on libhandy4-rs, which depends on libhandy4, and there is no package for libhandy4. According to libhandy4-rs, libhandy4 = libhandy1 built with GTK4 based on the merge request !625. That's way more experimental than I'm willing to handle, so dropping the package.

Anyone interested in saving this package, consider creating "libhandy-git"-like based on that merge request's branch and using it as dependency for this package.

Fanch commented on 2020-11-01 12:50

it lokk like there is also a dep on libhandy4 that I can't find on aur

Package 'libhandy-4', required by 'virtual:world', not found

Fanch commented on 2020-11-01 12:18

I think there is a missing dependencies: gtk4 As it does not build without it.

https://aur.archlinux.org/packages/gtk4/

bjo commented on 2020-08-05 21:59

Hi, add rust as a build dep.