Package Details: gnome-shell-pomodoro 0.19.1-1

Git Clone URL: https://aur.archlinux.org/gnome-shell-pomodoro.git (read-only, click to copy)
Package Base: gnome-shell-pomodoro
Description: A time management utility for GNOME based on the pomodoro technique
Upstream URL: https://github.com/gnome-pomodoro/gnome-pomodoro
Keywords: gnome management pomodoro time
Licenses: GPL3
Submitter: haaja
Maintainer: liamtimms
Last Packager: liamtimms
Votes: 103
Popularity: 1.54
First Submitted: 2014-01-11 17:23
Last Updated: 2021-04-09 20:23

Pinned Comments

liamtimms commented on 2021-03-26 01:05

With GNOME 40 hitting any day now (currently in staging), expect some problems with this package. I will update it as soon as upstream releases a new version but it may get borked for a little while. This is common with new GNOME releases and this particular release has more changes than usual. First week or so could be a little rough if you use a lot of extensions.

edit: it's been updated but there's a mistake upstream in 40 compatibility for this release. Expect a new release soon addressing this.

edit 2: rolled out to GNOME 40.

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 Next › Last »

corvinusz commented on 2016-06-15 04:46

Wed Jun 15 04:36:30 UTC 2016

$yaourt -Suya
---cut---
make[3]: *** No rule to make target 'gnome-pomodoro.h', needed by 'all-am'. Stop.
---cut---
make: *** [Makefile:414: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build gnome-shell-pomodoro.

Full listing:
https://paste.ee/p/dDwOU
will be available for 1 month

neitsab commented on 2015-11-10 13:38

Weirdly but happily enough, the 0.11.1 upstream release was built from the gnome-3.18 branch and not from master, therefore the extension works again after refreshing the shell. Yay!

gim commented on 2015-10-13 15:33

Users of this package will have to wait a release. As an alternative you can switch to a `gnome-shell-pomodoro-git` package which provides a development version of the extension with GNOME 3.18 support.
https://aur.archlinux.org/packages/gnome-shell-pomodoro-git/

neitsab commented on 2015-10-13 15:08

See https://github.com/codito/gnome-pomodoro/issues/195 for GNOME 3.18 compatibility.

vinilox commented on 2015-09-18 07:42

Gim, during the build process.
Thank you :)

gim commented on 2015-09-17 18:20

Ok, I see now after installing `docbook2x` again. I added both `docbook2x` and `perl-xml-sax-expat` as dependencies now, thank you!

gim commented on 2015-09-17 17:48

vinilox, this error appears during compile-time or a run-time? Could you show me the full output where this error appears please? I just removed `perl-xml-sax-expat` package from my system and it didn't seemingly affect the build process and it still works all right for me.

vinilox commented on 2015-09-17 15:12

Please add perl-xml-sax-expat as a dependency, it's needed or you will have this error :

Can't locate XML/SAX/Expat.pm in @INC (you may need to install the XML::SAX::Expat module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at (eval 5) line 1.

gim commented on 2015-07-09 19:23

That makes much more sense now. It looks like I couldn't reproduce this because I didn't have a "docbook2x" package installed, after installing the very same issue appeared. I'll fix PKGBUILD soon, thank you for investigation!

maus25 commented on 2015-07-09 19:14

Solved:
Added to pkgbuild before make:

sed -i "s/docbook2man \$?/docbook2man --sgml \$?/g" man/Makefile