Package Details: gnome-shell-extension-timepp-git v3.34_57_g767aa8c-1

Git Clone URL: https://aur.archlinux.org/gnome-shell-extension-timepp-git.git (read-only, click to copy)
Package Base: gnome-shell-extension-timepp-git
Description: A todo.txt manager, time tracker, timer, stopwatch, pomodoro, and alarm clock
Upstream URL: https://github.com/zagortenay333/timepp__gnome
Licenses: GPL3
Conflicts: gnome-shell-extension-timepp
Submitter: satriani
Maintainer: satriani
Last Packager: satriani
Votes: 4
Popularity: 0.91
First Submitted: 2019-02-08 19:56
Last Updated: 2020-12-12 22:54

Latest Comments

infotoni91 commented on 2020-12-11 16:53

Flagged out-of-date because of the error thrown in pkgver()

DVS9999 commented on 2020-06-19 23:37

Fix for the below issue (may be a better solution but this worked for me)

==> ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace. ==> ERROR: pkgver() generated an invalid version: v3.32-23-g34ae477

Modify the PKGBUILD line:-

git describe --always --tags

and append:-

| tr '-' '_'

Full line:-

git describe --always --tags| tr '-' '_'

Tio commented on 2019-03-30 12:50

Error:

Preparing...
Cloning gnome-shell-extension-timepp-git build files...
Checking gnome-shell-extension-timepp-git dependencies...
Building gnome-shell-extension-timepp-git...
==> Making package: gnome-shell-extension-timepp-git 8aa9b59-1 (sáb 30 mar 2019 13:50:14 CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Cloning timepp__gnome git repo...
Cloning into bare repository '/tmp/pamac-build/gnome-shell-extension-timepp-git/timepp__gnome'...
==> Validating source files with sha256sums...
    timepp__gnome ... Skipped
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of timepp__gnome git repo...
Cloning into 'timepp__gnome'...
done.
==> Starting pkgver()...
==> ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: v3.24--v3.30-4-g93a06ca