Package Details: gnome-shell-extension-hibernate-status-git r11.e358c28-1

Git Clone URL: https://aur.archlinux.org/gnome-shell-extension-hibernate-status-git.git (read-only)
Package Base: gnome-shell-extension-hibernate-status-git
Description: Gnome Shell extension that adds a hibernate/hybrid suspend button in Status menu.
Upstream URL: https://github.com/arelange/gnome-shell-extension-hibernate-status
Keywords: gnome
Licenses: GPL
Submitter: ryanvade
Maintainer: ryanvade
Last Packager: ryanvade
Votes: 9
Popularity: 0.000001
First Submitted: 2015-08-24 23:33
Last Updated: 2015-08-24 23:43

Latest Comments

zsolt-donca commented on 2019-11-11 09:27

It seems that, at the moment, the AUR build script is outdated and does not properly install the extension in its current form, as files are missing from the resulting package.

I've managed to fix it; below is my patch:

diff --git a/PKGBUILD b/PKGBUILD
index 8e15d7d..a5736bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
 #Packaged by ryanvade 

 pkgname=gnome-shell-extension-hibernate-status-git
-pkgver=r11.e358c28
+pkgver=r46.6afc7c6
 pkgrel=1
 pkgdesc="Gnome Shell extension that adds a hibernate/hybrid suspend button in Status menu."
 arch=('any')
@@ -29,4 +29,9 @@ package() {
     "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
   install -m644 "confirmDialog.js" \
     "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/confirmDialog.js"
+  install -m644 "prefs.js" \
+    "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/prefs.js"
+  glib-compile-schemas "schemas"
+  install -Dm644 "schemas/gschemas.compiled" \
+    "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/schemas/gschemas.compiled"
 }

kovalexal commented on 2019-05-19 16:45

Apparently, extension cannot be enabled on gnome 3.32.2. I get "Error loading extension" when I try to enable it in Tweak Tool. Hibernate using systemd is enabled in my system and works properly from console...

ryanvade commented on 2018-01-03 05:01

@mrkaspa: Hibernate is probably not enabled on your system. https://wiki.archlinux.org/index.php/Power_management/Suspend_and_hibernate

mrkaspa commented on 2017-12-04 14:57

I tried to install this on manjaro but when I'm gonna use it I hit the hibernate button and the computer doesn't do anything, do you know what could it be?

Taijian commented on 2016-12-09 13:04

@fthiery: you can upgrade -git packages with 'pacaur -Syu --devel --needed'. This will check -git packages for updates (--devel), but only rebuild them if an update is actually available (--needed).

fthiery commented on 2016-08-23 11:50

It would be good that you bump the package version (currently r11.e358c28-1) when a new gnome version comes out (or every time there is a commit) because otherwise the package doesn't upgrade: i installed this extension in the 3.18 days and since 3.20 it was "broken", i had to force installing the aur package.

But thanks for maintaining this !