Package Details: gnome-shell-extension-freon 44-1

Git Clone URL: https://aur.archlinux.org/gnome-shell-extension-freon.git (read-only, click to copy)
Package Base: gnome-shell-extension-freon
Description: Displays: CPU temperature, HDD/SSD temperature, video card temperature (nVidia/Catalyst), voltage and fan RPM in a GNOME Shell top bar pop-down.
Upstream URL: https://github.com/UshakovVasilii/gnome-shell-extension-freon
Licenses: GPL
Conflicts: gnome-shell-extensions-git
Submitter: WoefulDerelict
Maintainer: WoefulDerelict
Last Packager: WoefulDerelict
Votes: 19
Popularity: 0.70
First Submitted: 2015-07-23 22:29
Last Updated: 2021-04-19 16:57

Dependencies (6)

Required by (0)

Sources (1)

Latest Comments

Viski commented on 2021-04-26 09:29

I too got the failed sha512sum when updating the package with aurutils. When manually downloading and checking the package, there's no issue – the sha512sum matches.

I'd guess the issue is that the src is downloaded to a .tar.gz file which does not have a version number. makepkg seems to be happy when it finds an already existing src file and tries to use that instead of downloading the correct updated version. This of course leads to the mismatch in the hash.

If I remove the .tar.gz from aurutils' cache and rerun aur sync -u it works correctly.

I'm not sure whose fault it is. Should aurutils force makepkg to clean the cache before building? Or should the PKGBUILD always have version number in the source packages? Most other PKGBUILDs seem to keep the version number in the downloaded source files.

WoefulDerelict commented on 2020-11-20 23:57

GI_Jack: I can't reproduce that error. I've fetched the archive a number of times to verify checksum matches the one in the PKGBUILD.

GI_Jack commented on 2020-11-06 23:40

==> Validating source files with sha512sums... gnome-shell-extension-freon.tar.gz ... FAILED

Please fix

archuser5432 commented on 2019-10-07 22:24

Version 38 is broken under gnome shell 3.34. New version 39 with fix is out.

dbIsMe commented on 2019-03-20 23:42

This extension was broken by the Gnome 3.32 update. I see the developer has updated to v36 with fixes for this

https://github.com/UshakovVasilii/gnome-shell-extension-freon/releases

Hoping our package maintainer can update for us. TIA!

kerel commented on 2018-05-28 09:31

Hi, I installed this package with AUR-helper aurman, version 33-1 was installed. The update to 34-1 using aurman failed with

==> Making package: gnome-shell-extension-freon 34-1 (Mo 28. Mai 11:08:09 CEST 2018)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found gnome-shell-extension-freon.tar.gz
==> Validating source files with sha512sums...
    gnome-shell-extension-freon.tar.gz ... FAILED
2018-05-28 11:08:09,406 - wrappers - makepkg - ERROR - makepkg query makepkg -cf --noconfirm failed in directory /home/kerel/.cache/aurman/gnome-shell-extension-freon

It's caused by the filename of the source file being the same between different versions, preventing the download of the updated source file. I propose to add the pkgver to produce an unique filename (the filename is already unique at the upstream):

source=("${pkgname}-${pkgver}.tar.gz::https://github.com/UshakovVasilii/gnome-shell-extension-freon/archive/EGO-${pkgver}.tar.gz")

WoefulDerelict commented on 2018-02-28 15:38

souvik1997: I can not reproduce the issue. The integrity check succeeds and the package builds successfully on my test boxes. Start with a clean build environment and try again.