Package Details: gnome-perl 1.045-8

Git Clone URL: https://aur.archlinux.org/gnome-perl.git (read-only, click to copy)
Package Base: gnome-perl
Description: Perl bindings for libgnome
Upstream URL: http://gtk2-perl.sourceforge.net/
Licenses: LGPL
Submitter: PhotonX
Maintainer: PhotonX
Last Packager: PhotonX
Votes: 29
Popularity: 0.71
First Submitted: 2017-01-25 19:09
Last Updated: 2018-03-03 22:07

Latest Comments

« First ‹ Previous 1 2 3

Spyhawk commented on 2017-01-27 16:41

The issue arises with pacaur because it uses the RPC interface to compute the dependency tree (see https://aur.archlinux.org/rpc/?v=5&type=info&arg[]=gnome-perl). Bauerbill and aurutils are most probably affected by that issue as they also use the RPC. Yaourt and makepkg act on the PKGBUILD directly and do not rely on the .SRCINFO file, so they don't choke here.

The issue seems solved for now.

PhotonX commented on 2017-01-27 16:28

Right, i see the problem, thanks for the hint! .PKGINFO is also buggy, but for some reason pacman and yaourt do not complain... I also tried to echo the depends array and the output is correct:

echo "depends: ${depends[*]}"

gives

depends: gnomecanvas-perl gnome-vfs-perl libgnomeui perl perl>=5.24 perl<5.25

So whatever goes wrong here happens when generating .SRCINFO and .PKGINFO and this is nothing I can influence.

I simplified the perl version information to read "perl=5.24" (which is the same as "perl>=5.24 perl<5.25" as far as I understand - if there are some subtle differences, please let me know). Now .PKGINFO is correct but .SRCINFO is still buggy. Please test if this is sufficient for pacaur to install it correctly.

edit: Ok, I see the subtle difference, Perl has minor versions 5.24.x... Will think about how to deal with that... Since the installation fails due to this, I removed the version check completely for now... Hints or people who are willing to take care of the package are welcome. :)

Spyhawk commented on 2017-01-27 15:26

The AUR metadata is indeed buggy: https://aur.archlinux.org/cgit/aur.git/tree/.SRCINFO?h=gnome-perl&id=803915977ed8c2e5166733fa75e4ba29b88edcc9

For some reason, the min/max variable weren't successfully created on the machine that generated the .SRCINFO file.

rhabbachi commented on 2017-01-27 13:33

@PhotonX building and installing wokrs when using makepkg and pacman. Still don't work when using pacaur.

PhotonX commented on 2017-01-27 07:36

Could any of you please check if building and installing works when using makepkg and pacman rather than pacaur?

Ghosthree3 commented on 2017-01-26 23:08

No good here still.

% pacaur --sync gnome-perl
:: resolving dependencies...
:: no results found for perl<
:: no results found for gnome-vfs

PhotonX commented on 2017-01-26 19:21

Please try if pacaur can handle the installation now.

edit: Sorry, had to revert the change, since it broke the installation for yaourt. What do you mean by "empty min/max"? You can run

perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);'

and see whether it returns something on your machine. In my case it returned 5.24.

PhotonX commented on 2017-01-26 14:48

I have just copied the PKGBUILD from Arch's official repos so far. Building with makepkg worked for me, does it work for you?

I will have a closer look at the problem in the evening.

blueyed commented on 2017-01-26 14:29

I guess it should skip "depends+=("perl>=$_perlver_min" "perl<$_perlver_max")" for empty min/max?!

blueyed commented on 2017-01-26 14:26

The depends for perl are weird, and cause pacaur to fail:

++ GetJson var '{"version":5,"type":"multiinfo","resultcount":1,"results":[{"ID":377733,"Name":"gnome-vfs-perl","PackageBaseID":119151,"PackageBase":"gnome-vfs-perl","Version":"1.082-4","Description":"Gnome2-VFS perl bindings for gnome-vfs","URL":"http:\/\/gtk2-perl.sourceforge.net\/","NumVotes":0,"Popularity":0,"OutOfDate":null,"Maintainer":"PhotonX","FirstSubmitted":1485371787,"LastModified":1485371787,"URLPath":"\/cgit\/aur.git\/snapshot\/gnome-vfs-perl.tar.gz","Depends":["gtk2-perl","gnome-vfs","perl","perl>=","perl<"],"MakeDepends":["perl-extutils-pkgconfig","perl-extutils-depends"],"License":["LGPL"],"Keywords":[]}]}' Name

:: resolving dependencies...

:: no results found for perl<