Package Details: gnash-git 0.8.11.r22377.g2b3bded-1

Git Clone URL: https://aur.archlinux.org/gnash-git.git (read-only, click to copy)
Package Base: gnash-git
Description: The GNU SWF Player based on GameSWF - git development version
Upstream URL: http://www.gnu.org/software/gnash/
Licenses: GPL3
Conflicts: gnash, gnash-common, gnash-gtk
Provides: gnash, gnash-common, gnash-gtk
Replaces: gnash, gnash-common, gnash-gtk
Submitter: smoge
Maintainer: giorgianb
Last Packager: christoph.gysin
Votes: 68
Popularity: 0.002615
First Submitted: 2011-05-26 21:04
Last Updated: 2016-08-15 16:08

Dependencies (25)

Required by (1)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

jsteel commented on 2014-11-02 12:51

Merging gnash-trunk-git into gnash-git. Bother were orphans; feel free to adopt.

FredBezies commented on 2014-10-29 06:57

Just using html5 video and audio rendering on compatible sites.

taro-k commented on 2014-10-29 01:44

Oh, why? Any security problem?

FredBezies commented on 2014-10-28 18:18

Don't use it anymore. Orphaning it.

taro-k commented on 2014-10-28 16:28

@tmtvl
For current AUR version, gnash-trunk-git 0.8.11.r22195.g7349e86-1,
by gcc version 4.9.1 20140903 (prerelease) (GCC),
makepkg succeeded with your suggestion. thx.

taro-k commented on 2014-10-16 04:02

Hi, my system:
gnash-trunk-git pkgver=0.8.11.r22230.g21b977d
gcc version 4.9.1 20140903 (prerelease) (GCC)

and makepkg fails with/without your suggestion.

[code]
CXX libgnashbase_la-GnashImageGif.lo
GnashImageGif.cpp: In destructor 'virtual gnash::image::{anonymous}::GifInput::~GifInput()':
GnashImageGif.cpp:123:23: error: too few arguments to function 'int DGifCloseFile(GifFileType*, int*)'
DGifCloseFile(_gif);
^
In file included from GnashImageGif.cpp:27:0:
/usr/include/gif_lib.h:183:9: note: declared here
int DGifCloseFile(GifFileType * GifFile, int *ErrorCode);
^
Makefile:1257: recipe for target 'libgnashbase_la-GnashImageGif.lo' failed
make[2]: *** [libgnashbase_la-GnashImageGif.lo] Error 1
make[2]: Leaving directory '/mnt/tmp/aur/gnash-trunk-git/src/gnash/libbase'
Makefile:1145: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/mnt/tmp/aur/gnash-trunk-git/src/gnash'
Makefile:1052: recipe for target 'all' failed
make: *** [all] Error 2
[/code]

tmtvl commented on 2014-10-15 17:12

AS I said upstream, a possible workaround for the bug is to edit libcore/DragState.h:64:
bool hasBounds() const {
-return (_bounds);
+return (NULL != _bounds);
}

On my system it works, but on a system running gcc 4.8.2 it failed, so anyone who runs into the problem could let me know if it helps, that would be useful.

FredBezies commented on 2014-09-11 15:43

giflib bug is fixed, but another one appeared :

http://savannah.gnu.org/bugs/?43198

No update until this one is fixed.

FredBezies commented on 2014-08-17 16:25

Orphaning it. @melkhatt : if you want it, feel free to adopt it !

FredBezies commented on 2014-08-13 06:44

@melkhatt : gnash doesn't build against last giflib. Will try with giflib-nox11, but as gnash is using x11 and any browser to work with it...

I try downgrading giflib, but it will conflict with another packages. Will have to wait until gnash code is updated.