Package Details: gmsh 4.8.4-1

Git Clone URL: https://aur.archlinux.org/gmsh.git (read-only, click to copy)
Package Base: gmsh
Description: An automatic 3D finite element mesh generator with pre and post-processing facilities.
Upstream URL: http://gmsh.info/
Licenses: custom
Submitter: S1G1
Maintainer: gborzi
Last Packager: gborzi
Votes: 55
Popularity: 0.084591
First Submitted: 2006-04-04 23:31
Last Updated: 2021-05-02 14:27

Latest Comments

1 2 3 4 5 6 ... Next › Last »

libreliu commented on 2021-05-05 07:26

Thanks for the package ;)

Got the following error while trying to install with yay -S gmsh:

[ 98%] Building CXX object CMakeFiles/gmsh.dir/api/gmshc.cpp.o
[ 98%] Built target shared
[100%] Linking CXX executable gmsh
[100%] Built target gmsh
Generating ../doc/texinfo/gmsh.info
Generating ../doc/texinfo/gmsh.html
Generating ../doc/texinfo/gmsh.txt
Generating ../doc/texinfo/gmsh.pdf
/usr/bin/texi2dvi: TeX neither supports -recorder nor outputs \openout lines in its log file
make[3]: *** [CMakeFiles/doc.dir/build.make:131: ../doc/texinfo/gmsh.pdf] Error 1
make[3]: *** Waiting for unfinished jobs....
make[2]: *** [CMakeFiles/Makefile2:762: CMakeFiles/doc.dir/all] Error 2
make[1]: *** [CMakeFiles/Makefile2:769: CMakeFiles/doc.dir/rule] Error 2
make: *** [Makefile:303: doc] Error 2

The error was probably raised in LC_ALL=C make doc.

capitalaslash commented on 2021-02-16 10:22

please update python installation path to 3.9

gborzi commented on 2020-11-12 19:41

@gdolle Now it's fixed. I've added an environment script for csh as well.

gdolle commented on 2020-11-12 17:42

Hi @gborzi, no unfortunately in both cases, overloading JULIA_LOAD_PATH seems to be the way, ju does not have standard path similar to python site-package directory to my knowledge.. (See https://docs.julialang.org/en/v1/manual/environment-variables/#JULIA_LOAD_PATH). I think /usr/share/gmsh/<path_somewhere> may avoid you headache in the future with other pkg. Best, G.

gborzi commented on 2020-11-12 15:54

@gdolle Thanks for the comment. I don't know the julia framework, so I have a question on where to put the file: if the file is under /usr/share/julia/gmsh will julia be able to read it without the need to have a file under /etc/profile.d? i.e. will it be already in the load path under /usr/share/julia/gmsh? If so, I'd prefer this solution.

gdolle commented on 2020-11-11 21:47

It might be better to move gmsh.jl from /usr/lib since it is not a shared library. Maybe /usr/share/gmsh/api/julia/ (or /usr/share/julia/gmsh ?) and add an environment script /etc/profile.d/gmsh.sh with

export JULIA_LOAD_PATH="/usr/share/gmsh/api/julia/:$JULIA_LOAD_PATH" (or "@gmsh")

Then it would work out of box in julia command line import gmsh.

gborzi commented on 2020-10-21 10:33

@newsboost Looks like the problem is with the voro++ package. The source for voro++ couldn't be downloaded during your attempt to compile. Now it downloads without problem. Please retry the installation.

newsboost commented on 2020-07-21 12:08

I try to install via "yay -S gmsh" but get:

...
==> Validating source files with md5sums...
    ann_1.1.2.tar.gz ... Passed
    shared-libs.patch ... Passed
    parallel.patch ... Passed
==> Making package: voro++ 0.4.6-1 (2020-07-21T14:04:31 CEST)
==> Retrieving sources...
  -> Downloading voro++-0.4.6.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (7) Failed to connect to math.lbl.gov port 80: Connection refused
==> ERROR: Failure while downloading http://math.lbl.gov/voro++/download/dir/voro++-0.4.6.tar.gz
    Aborting...
error downloading sources: voro++

Anyone knows what's wrong (or a work-around/solution or something)?

gborzi commented on 2020-07-03 14:22

Sorry for the delay in adding the glu dependency, but I've been quite busy lately.

lahwaacz commented on 2020-07-03 08:47

glu needs to be added to depends (not just makedepends), because both /usr/bin/gmsh and /usr/lib/libgmsh.so are directly linked to libGLU.so.1.