Package Details: glibc-2.27 2.27-3

Git Clone URL: https://aur.archlinux.org/glibc-2.27.git (read-only)
Package Base: glibc-2.27
Description: GNU C Library, version 2.27
Upstream URL: http://www.gnu.org/software/libc
Licenses: GPL, LGPL
Groups: base
Submitter: buzo
Maintainer: buzo
Last Packager: buzo
Votes: 1
Popularity: 0.000078
First Submitted: 2018-08-08 19:12
Last Updated: 2018-08-08 19:12

Latest Comments

dmitry_k commented on 2018-12-10 19:10

When trying to import the following key: 7273542B39962DF7B299931416792B4EA25340F8, required by: glibc-2.27

I'm getting this error: gpg: keyserver receive failed: No data.

What could be done about it?

cpuheater commented on 2018-10-02 19:36

Since the files are eventually placed in /opt/glibc-2.27, I think we should let the configure script know, so if it hardcodes any paths into the library they will be correct.

When trying to compile gcc5 with glibc-2.27 I had an issue where the compiler would look for a file called "/usr/lib/libpthread_nonshared.a" whereas the file was actually at "/opt/glibc-2.27/usr/lib/libpthread_nonshared.a". However the issue was hard to reproduce in an isolated way.

Here's my approach: https://gist.github.com/a7791b6326522d3ad2e5958934d1f7c7

I tested it by compiling a small statically linked test program but I don't know if this is the correct way to do it.

buzo commented on 2018-08-08 19:14

For a reasonably fast build time, add the option --nocheck to makepkg.