Package Details: glib 1.2.10-18

Git Clone URL: https://aur.archlinux.org/glib.git (read-only, click to copy)
Package Base: glib
Description: Common C routines used by Gtk+ and other libs
Upstream URL: http://www.gtk.org/
Licenses: LGPL
Submitter: ConnorBehan
Maintainer: ConnorBehan
Last Packager: ConnorBehan
Votes: 102
Popularity: 1.37
First Submitted: 2014-05-22 01:43
Last Updated: 2021-05-03 09:55

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

salmonix commented on 2021-01-20 17:23

Same error here.

phuhl commented on 2021-01-05 12:12

Fails to build for me, running yay -Syu outputs lots of stuff, but near the end:

#...
/bin/sh ./libtool    --mode=compile gcc -DHAVE_CONFIG_H -I. -DG_LOG_DOMAIN=g_log_domain_glib   -D_FORTIFY_SOURCE=2  -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -Wall  -MT garray.lo -MD -MP -MF .deps/garray.Tpo -c -o garray.lo garray.c
libtool: Version mismatch error.  This is libtool 2.4.6.42-b88ce-dirty, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.6.42-b88ce-dirty
libtool: and run autoconf again.
make[2]: *** [Makefile:722: garray.lo] Fehler 63
# ...

tamjan commented on 2020-11-29 13:06

Patch for armv6h support:

--- /dev/fd/63  2020-11-29 14:03:35.896117067 +0100
+++ PKGBUILD    2020-11-29 11:27:47.244672027 +0100
@@ -5,7 +5,7 @@
 pkgver=1.2.10
 pkgrel=15
 pkgdesc="Common C routines used by Gtk+ and other libs"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv6h')
 url="http://www.gtk.org/"
 license=('LGPL')
 depends=('glibc' 'sh')
@@ -31,6 +31,8 @@
     CONFIGFLAG='--host=i686-pc-linux-gnu --target=i686-pc-linux-gnu'
   elif [[ $CARCH = "x86_64" ]]; then
     CONFIGFLAG='--host=x86_64-unknown-linux-gnu --target=x86_64-unknown-linux-gnu'
+  elif [[ $CARCH = "armv6h" ]]; then
+    CONFIGFLAG='--host=armv6l-unknown-linux-gnueabihf --target=armv6l-unknown-linux-gnueabihf'
   fi

   autoreconf --force --install

Hedd commented on 2020-11-06 17:11

The download url (ftp://ftp.gnome.org/pub/gnome/sources/glib/1.2/glib-1.2.10.tar.gz) is broken. The file is available at https://download.gnome.org/sources/glib/1.2/glib-1.2.10.tar.gz

R1cochet commented on 2017-05-11 20:33

Unable to build using `makepkg -e`

I have glib-1.2.10 extracted in src dir

Fails with error:
https://pastebin.no/putuwanelo.pas

Musikolo commented on 2017-05-09 03:16

@ConnorBehan, makes sense.

Thank you!

ConnorBehan commented on 2017-05-09 02:46

AUR packages are supposed to assume that all of base-devel is installed.

Musikolo commented on 2017-05-09 02:19

@ConnorBehan, the following line should added to the PKGBUILD script:

makedepends=('autoconf')

I was getting the following error otherwise:
- https://pastebin.no/mukubaguho.coffeescript

Thank you!

nightside commented on 2016-08-16 20:39

I try to install today and it worked :)

ConnorBehan commented on 2016-08-16 19:04

Because your system doesn't like ftp? It works for me.