Package Details: glassfish5 5.1.0-2

Git Clone URL: https://aur.archlinux.org/glassfish5.git (read-only)
Package Base: glassfish5
Description: The Open Source Jakarta EE 8 (Java EE 8) Reference Implementation.
Upstream URL: https://github.com/eclipse-ee4j/glassfish
Keywords: glassfish java
Licenses: EPL
Submitter: morealaz
Maintainer: Marcel_K
Last Packager: Marcel_K
Votes: 3
Popularity: 0.000327
First Submitted: 2017-08-08 08:19
Last Updated: 2019-04-09 23:07

Latest Comments

Marcel_K commented on 2019-06-01 11:26

@Khaithang: sorry for the late reply, but I didn't have an internet connection at home last month. Yes, as far as I can see, I fixed the permission problem. Thanks for letting me know.

Khaithang commented on 2019-05-04 20:20

@polytheme , you should manage it with systemd. Just how you manage apache server with root. It comes with glassfish5.service for a reason

polytheme commented on 2019-04-09 10:21

There is a problem in current release: it installs all the files of glassfish readable only by root so no-one except root could not read and use any jar:
-rw-r----- 1 root root 41763 апр 9 07:45 shoal-gms-api.jar
-rw-r----- 1 root root 363754 апр 9 07:45 shoal-gms-impl.jar
-rw-r----- 1 root root 24823 апр 9 07:45 simple-glassfish-api.jar
-rw-r----- 1 root root 48445 апр 9 07:45 soap-tcp.jar
-rw-r----- 1 root root 33969 апр 9 07:45 ssl-impl.jar
-rw-r----- 1 root root 95444 апр 9 07:45 stats77.jar
-rw-r----- 1 root root 169541 апр 9 07:45 stax2-api.jar
-rw-r----- 1 root root 31625 апр 9 07:45 tiger-types.jar
-rw-r----- 1 root root 36655 апр 9 07:45 transaction-internal-api.jar
-rw-r----- 1 root root 70414 апр 9 07:45 tyrus-client.jar

(that's part of content of /opt/glassfish5/glassfish/modules folder)

morealaz commented on 2017-09-23 17:48

@Marcel_K: sorry for the link! I fixed it. thanks for noticing.

Marcel_K commented on 2017-09-23 15:48

The download link is incorrect: as GlassFish 5 is no longer in beta, you should change 'promoted' to 'release'.

morealaz commented on 2017-08-08 11:09

@Marcel_K: sorry about error and thanks for information about PKGBUILD. I fix it.

Marcel_K commented on 2017-08-08 10:04

I get a 404. And I think your conflicts is wrong: how can a package conflict with itself? And provides is not necessary in this case, it's redundant. Moreover, you should surround all instances of $srcdir and $pkgdir (and derivatives) with double quotes.